Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VL bugs

E Tolle

New Member
Joined
Apr 4, 2009
Messages
2
Reaction score
0
Points
0
Members Ride
VL
Hi, I’m having some strange issues with the VL, 3.0 ltr.

It was going crap about 4 months ago batteries going flat overnight & while driving. I sorted that out with new terminals and a reco’d Alternator, and new ignition leads.


Now for some reason the dash lights dim intermittently and the wipers slow up when their going. So on both speeds the wipers are slower than they should be.

Also the car seems to have lost power......going up a big long hill that it would normally have no issue with at 110 kph.......it struggles to maintain 90 kph. It is also just generally sluggish now.

The power button on the auto trans doesn’t work now either.

Anyone come across these symptoms before
 

jatsvl

NEEDS MORE POWER!
Joined
Nov 21, 2006
Messages
959
Reaction score
16
Points
0
Location
Adelaide
Members Ride
vl exec wagon
electrical issues maybe bad earth either on the engine or the body near the battery.
slow up hills maybe you need a trans service.
 

E Tolle

New Member
Joined
Apr 4, 2009
Messages
2
Reaction score
0
Points
0
Members Ride
VL
electrical issues maybe bad earth either on the engine or the body near the battery.
slow up hills maybe you need a trans service.
Thanks mate, I'll have a look into it............
 

Goon

Scientific Tuning
Joined
Feb 20, 2006
Messages
2,508
Reaction score
9
Points
38
Location
BrisVegas. QLD
Members Ride
VY CUSTOM.
the power button should come on when the ride has warmmed up.. check ur light globe in ur dash incase its blown and u cant notice it working but u should with the revs drop or increase.. i wouldnt use it above 80 either..

depending on the hill ur going up, if its really steap and u dont see it coming.. well she wont zoom up it.. the more u push it the worst it is for ur motor and mad fuel usage...

get a service done on it... if ur exhasut has holes in it youll lose compression..

get a new battery if u havent changed that..

thats all i can think of...:drink:
 
Top