Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Vl turbo won't rev past 4000-4500rpm

Discussion in 'VL Holden Commodore (1986 - 1988)' started by Twitcha007, Feb 13, 2018.

  1. Twitcha007

    Twitcha007 New Member

    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Feb 13, 2018
    Location:
    Tamworth
    Members Ride:
    Vl SL turbo
    Hey guys ive got a problem with my vl turbo , it doesn't seem to won't to rev out past 4500rpm in any gear. Ive replaced spark plugs with bcpr7es with 0.8 gap, changed fuel pump to brand new genuine bosch 044, changed fuel filter, replaced coil with a ice 4100. Nothing seems to work , car runs fine other then the fact it won't rev out past 4500rpm..has a microtech lt8s ecu. Was doing the same thing before I replaced anything I listed. Any1 possibly have a idea what it could be, before I take it to be retuned . cheers
     
  2. Lacksballs

    Lacksballs Active Member

    Messages:
    173
    Likes Received:
    50
    Trophy Points:
    28
    Joined:
    Jul 24, 2014
    Location:
    Sydney
    Members Ride:
    VK Group C Replica
    I'm guessing that the rev limit may be set @ 4500RPM??? Unless it has a 2 step switch that is active?????
     
  3. dgp

    dgp Well-Known Member

    Messages:
    1,209
    Likes Received:
    352
    Trophy Points:
    83
    Joined:
    Jan 1, 2011
    Location:
    Warrnambool
    Members Ride:
    VF II SSV Redline
    On one of mine many years ago I had a problem with either the crank angle sensor or the cam angle sensor which caused some drama like you describe, can't remember which sensor though.
     
  4. Deuce

    Deuce Super Stock

    Messages:
    1,522
    Likes Received:
    203
    Trophy Points:
    63
    Joined:
    Feb 5, 2012
    Location:
    Meremere Dragway (as often as possible)
    Members Ride:
    '94 VR SS V8
    My first thought was coils, but you have replaced that.
    Does it rev freely and cleanly up to 4500?
     
  5. EYY

    EYY Well-Known Member

    Messages:
    3,782
    Likes Received:
    447
    Trophy Points:
    83
    Joined:
    Mar 6, 2011
    Location:
    Vic
    Members Ride:
    VS Statesman
    Sell it to me, it’s obviously irrepairable :p
     
  6. Twitcha007

    Twitcha007 New Member

    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Feb 13, 2018
    Location:
    Tamworth
    Members Ride:
    Vl SL turbo
    It revs good when not under load , underload revs fine until 4500rpm and just hits a brick wall sort of thing, throws you forward ...it does have a rev limiter on the microtech but its set at 6000rpm I've checked that a few times...I was thinking that CAS but pulled dizzy cap etc off the other day and its clean , no red dust from bearing etc. And it only does it at 4000rpm to 4500rpm dependent on how I use the throttle
     
  7. EYY

    EYY Well-Known Member

    Messages:
    3,782
    Likes Received:
    447
    Trophy Points:
    83
    Joined:
    Mar 6, 2011
    Location:
    Vic
    Members Ride:
    VS Statesman
    I’d remove the limiter and see what happens. Does it feel like a limiter? Feels like it pulls well up to exactly 4500?
     
  8. Twitcha007

    Twitcha007 New Member

    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Feb 13, 2018
    Location:
    Tamworth
    Members Ride:
    Vl SL turbo
    Yeah pulls great on 20psi until it just stops pulling , but yes it sort of does feel like a rev limiter but its set at 6000rpm , its not getting close to that at all...I'll try turning it up to 7000rpm and see what happens...
     
  9. Lacksballs

    Lacksballs Active Member

    Messages:
    173
    Likes Received:
    50
    Trophy Points:
    28
    Joined:
    Jul 24, 2014
    Location:
    Sydney
    Members Ride:
    VK Group C Replica
    HT leads breaking down???
     
  10. Deuce

    Deuce Super Stock

    Messages:
    1,522
    Likes Received:
    203
    Trophy Points:
    63
    Joined:
    Feb 5, 2012
    Location:
    Meremere Dragway (as often as possible)
    Members Ride:
    '94 VR SS V8
    20psi blowing out the spark?
     
  11. Lacksballs

    Lacksballs Active Member

    Messages:
    173
    Likes Received:
    50
    Trophy Points:
    28
    Joined:
    Jul 24, 2014
    Location:
    Sydney
    Members Ride:
    VK Group C Replica
    Pull some boost out, say 10psi then slowly up it to see where the problem occurs.
     
  12. Twitcha007

    Twitcha007 New Member

    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Feb 13, 2018
    Location:
    Tamworth
    Members Ride:
    Vl SL turbo
    I've tried it on 10psi even 8psi still does it at exactly 4500rpm every time. Plugs are gapped to 0.8 which shouldn't be blowing out with 10psi
     
  13. delcowizzid

    delcowizzid on holiday

    Messages:
    6,542
    Likes Received:
    197
    Trophy Points:
    63
    Joined:
    Jul 8, 2008
    Location:
    NZ
    Members Ride:
    в∞ѕтεכ √&
    Borrow a dizzy and see if it fixes it or check and make sure the chopper wheel is up the right way in the dizzy that causes issues .the dizzy do for even when there' no orange rust dust in there
     
  14. Lacksballs

    Lacksballs Active Member

    Messages:
    173
    Likes Received:
    50
    Trophy Points:
    28
    Joined:
    Jul 24, 2014
    Location:
    Sydney
    Members Ride:
    VK Group C Replica
    OK, so at what boost does it cut out at?
     
  15. Twitcha007

    Twitcha007 New Member

    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Feb 13, 2018
    Location:
    Tamworth
    Members Ride:
    Vl SL turbo
    Hey mate sorry but not sure what the chopper wheel is haha did u mean rotor button?
     
  16. Twitcha007

    Twitcha007 New Member

    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Feb 13, 2018
    Location:
    Tamworth
    Members Ride:
    Vl SL turbo
    It makes 20psi on 20psi by 4200rpm and then cuts out at 4500rpm so makes boost and then quits. Its just confusing really , like its the crank angle sensor but runs fine drives fine etc until 4500rpm sometimes 4400rpm or 4700rpm but never get it over 5000rpm and never happens before 4000rpm
     
  17. chrisp

    chrisp Active Member

    Messages:
    240
    Likes Received:
    96
    Trophy Points:
    28
    Joined:
    Dec 9, 2009
    Location:
    Melbourne Victoria
    Members Ride:
    VF2 MY16 SS Redline Sportwagon
    It’s in the distributor and serves as a crank angle sensor and timing marks for the ignition timing. The optical encoder used in it is a well known common fault in the RB30. I’d suggest changing/swapping it before doing too much else.
     
  18. chrisp

    chrisp Active Member

    Messages:
    240
    Likes Received:
    96
    Trophy Points:
    28
    Joined:
    Dec 9, 2009
    Location:
    Melbourne Victoria
    Members Ride:
    VF2 MY16 SS Redline Sportwagon
  19. Lacksballs

    Lacksballs Active Member

    Messages:
    173
    Likes Received:
    50
    Trophy Points:
    28
    Joined:
    Jul 24, 2014
    Location:
    Sydney
    Members Ride:
    VK Group C Replica
    Do you a garage or tuner close by that has a dyno that can check the ignition system under-load, it will be cheaper in the long run rather than throwing more new bits at it.. Unless you have a spare dizzy to throw in it first..
     
  20. Twitcha007

    Twitcha007 New Member

    Messages:
    9
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Feb 13, 2018
    Location:
    Tamworth
    Members Ride:
    Vl SL turbo
    I'm just going to try try a new crank angle sensor tomorrow , there only roughly $100 and that way I know its new etc , if that fails I'm going to a mechanics but not to keen on taking it there to be charged $100 an hour for them to probably not even sort it out. We have one dyno tuning joint in Tamworth NSW, I've heard mixed results about them being decent at what they do and also being rather average, abit hesitant, but it will be my only option left unless I want to trailer it to Newcastle or Sydney ...cheers everyone I'll let use know the results whenever I get it sorted
     

Share This Page