Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

vn heater not working

onlinejames

Member
Joined
Oct 1, 2007
Messages
34
Reaction score
0
Points
6
My dads heater isnt working, so t checked the heater tap, and its not working , inside is on hot and there isnt any vacuum to the tap also there doesnt seem to be any hot water getting to the tap , its a 4 hose tap
The top hose point goes to a metal pipe on the motor and goes to the front of the motor, it also goes to the bottom of the overflow bottle( what eva its called ), i removed the top hose to find no water came out , started the car and after a while just got steam coming out, no water coming out of the tap or hose
has anyone got any ideas whats wrong, and where is the thermostat located
is there any links to a step by step guide to how to remove heater core without taking out the dash, did that once with my xr6 swore to never do it again LOL
also yeah it has issues LOL, the fuel gauge isnt accurate for some reason and the speedo looks like its not working then suddenly it jumps up and works fine, any ideas ???
thanks guys
 

88GreenVN

Next Exit Left
Joined
Jun 12, 2006
Messages
6,795
Reaction score
134
Points
63
Age
57
Location
Surprise, Arizona
Members Ride
Dodge Ram Van 1500 5.2 V8
I'd look at the vac lines first of all.

Is the heater rod connected properly.
 

calais_cruzin

Calais_Rattling....
Joined
May 23, 2006
Messages
1,297
Reaction score
10
Points
0
Location
Gold Coast
Members Ride
92 VP Calais 3.8
The thermostat will be at the back of the motor behind the throttle body, u have a S1 motor as ur overflow has the pipe at the bottom. It has a screw down cap right?

Just follow where the top radiator hose leads, the thermostat will be under the hose mount at the motor.

Also i would hold or tie the heater tap open, run the car and see if the heater works, or if all 4 hose's at the heater tap feel hot.
 

onlinejames

Member
Joined
Oct 1, 2007
Messages
34
Reaction score
0
Points
6
heater rod is ok, the vacuum line runs inside the car, not sure where it goes from there, has no vacuum at all
yea it has a screw down cap, i actually put a cable tie on it and ran for a while till the temp got to half and the hoses werent hot, could easily hold them, the one that runs to the motor, the top hose which also runs to the water doesnt get hot, when i disconnected it , i got no water just steam, i later had to put 4L of water in the car as it was low but i didnt lose that much water, even with the motor running i had no water out of that hose to the motor, the water bottle had water in it too
 

88GreenVN

Next Exit Left
Joined
Jun 12, 2006
Messages
6,795
Reaction score
134
Points
63
Age
57
Location
Surprise, Arizona
Members Ride
Dodge Ram Van 1500 5.2 V8
vac line runs to the vac ball under the front left gaurd.
 

onlinejames

Member
Joined
Oct 1, 2007
Messages
34
Reaction score
0
Points
6
i seen that, it runs from motor to t piece one that goes into car, the other under guard, there is vacuum to that line, where does it go from the guard, how do i trace it back to heater tap
thanks guys
 

calais_cruzin

Calais_Rattling....
Joined
May 23, 2006
Messages
1,297
Reaction score
10
Points
0
Location
Gold Coast
Members Ride
92 VP Calais 3.8
how hot is the car gettin, does it over heat. it should be by what ur sayin.

you should have water comin out that top hose if the gauge is above the 1st notch

if it is n only steam comin out you have no water pressure to circulate the water, heater wont work also car will over heat. New water pump
 

onlinejames

Member
Joined
Oct 1, 2007
Messages
34
Reaction score
0
Points
6
i havnt driven it far but only goes half way when driving, my dad never complained about over heating though, was low in water, if the hose that connects to the water bottle and heater tap had pressure wouldnt it come out of the water bottle?
 

centy

Member
Joined
Jun 29, 2008
Messages
911
Reaction score
6
Points
18
Members Ride
Vp series 2
very simple.
fill with water, then do everything up tight.
Run till hot then squeeze the top radiator hose.
If it is soft then you have a leak if it is cold then no water is circulating.
these engines run about 90 deg c.
You have to bleed the system when you fill it to.
 
Top