Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

vn v8 motor problems

overclocked23

Member
Joined
Mar 23, 2009
Messages
31
Reaction score
0
Points
6
Members Ride
Vp V8
i have a vn v8 and im having trouble with the motor when i get in to the higher rpm the motor breaks down like missing as well as it feels like the engine is laggy as well . i replaced the fuel filter and when i did the element inside was loose and was not filtering at all and was clogged to the **** house as we opened it up cause never seen one were the element was loose , i was thinking of replacing the internal and external pumps and the regulator and injectors, as well as that the car starts stright away when cold but once warmed up it takes a bit more cranking over so that gets me thinkin its the pumps any help would be nice thanks
 

VrWagz1

The Wagon on Wheels..
Joined
May 5, 2008
Messages
2,438
Reaction score
29
Points
48
Location
wollongong
Website
www.wagzhome.justcommodores.com.au
Members Ride
VE SSV MY09 Auto Wagon
They can be a bit hard to start when hot. Try turning the key once so the pump will prime for just a few seconds and then off and then back on let it prime again and then crank. Works with mine.

If its starts spluttering up high it can be a dodgy dizzy cap and even your leads. How long since you done the spark plugs. Generally but not always if it lacks fuel it will just run boggy as opposed to miss firing.
 

greenfoam

New Member
Joined
Jan 13, 2005
Messages
7,902
Reaction score
125
Points
0
Age
99
Members Ride
VP Executive R-spec
Coil maybe
 

overclocked23

Member
Joined
Mar 23, 2009
Messages
31
Reaction score
0
Points
6
Members Ride
Vp V8
well changed the sparkplugs yesterday i will try the leads and cap and c what happens thanks
 

Vt-Brrrlina

vp bt1 gts replica
Joined
May 2, 2006
Messages
521
Reaction score
4
Points
0
Location
Perth, Western Aust
Members Ride
vp bt1 5.0ltr full GTS kit
if ya doin the cap do the rotor same time - mine was cracked causing backfiring and laggy car
 

spirto

Member
Joined
Aug 2, 2006
Messages
213
Reaction score
3
Points
18
Location
Adelaide
Members Ride
VQ Caprice II
Hey guys,
If it is hard to start when it's hot, it is usually caused by the one or more injectors dribbling into the inlet manifold when it is parked. It takes two or three cranks as it has to spit out the extra fuel. When you turn the key again it will only add more fuel. A quick test is to remove the fuel pump fuse and start it when hot, if it starts quickly then stall then it will confirm that the fuel injectors are dribbling.

In regards to your engine performance up high, sounds like a coil or leads, spark plugs tend to misfire only at low rpm almost idle. I would also check the fuel regulator located at the rear of the driver side bank, there is a little vacuum hose that can split causing the fuel to not flow.

Another check and quite common is inside the distrubuter there are mechanical wieghts to allow the dizzy to advance as needed, these can become stuck or rusted. Ebay sells new dissys all the time.

Hope this helps.
 

Reaper

Tells it like it is.
Joined
Aug 15, 2004
Messages
6,453
Reaction score
7,013
Points
113
Location
SE Suburbs, Melbourne
Members Ride
RG Z71 Colorado, 120 Prado , VDJ200 Landcruiser
coil / leads / plugs.
I'd put money on coil myself. Fix all vac lines. Dizzy advance is done in the ECU. If you put a procomp dizzy in your car you will be banished from jc hence forth.

Reaper
 
Top