Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VR 5.0L V8 fuel issues

adamR

New Member
Joined
Aug 15, 2013
Messages
9
Reaction score
0
Points
0
Location
rotorua nz
Members Ride
1994 VR 5.0L
Greetings,

i'm a noob to this forum, so before i pick your guys brains introductions are in order :D

my name is adam from rotorua nz, i have a number of cars, but my fav is my vr....... i also have a wrx-ra, and an fto.

my VR is a v8 conversion,.. was a v6 executive and had a 304ci efi put in by the previous owner...i never had a single issue with it....heaps of power, pulls all day, hills no issue, no smoke, oil or water leaks... but when it came time to get a new warrant of fitness it failed because the custom external fuel pump was not legal. they said it had to be removed...so i had it removed...replaced with another VR fuel pump.

i took the car to a mechanic who put a (used) fuel pump in it. it worked well for 60 kms, however, the car slowly ran out of power....to the point where all it did was crawl home and splutter. i returned to car to the mechanic who put another (used) fuel pump in..... that worked, but again only for 60 or so kms, before it started to lose power and crawl, misfire,......

aaarrrrgh!!!!!

i am only guessing, but would i need to replace the fuel pump with another custom one? my thoughts are the car is calling for more petrol then the standard pump can handle...???? i guess that, because the only thing i did was change from a custom pump to a stock one...... does this sound like the issue? i hope so.....

here come my questions...what should i do???? the obvious thing would be to put another big custom pump on it....perhaps change the fuel filters? check ignition leads, plugs and distributor ? would it be starving for gas because a standard pump is being over worked? why would the car blow more pumps?....

i'm pretty gutted, my vr has been off the road for weeks now and i miss it...lol :D

thanks in advance for any ideas you can give me :D

cheers
adam
 

DavoVP

New Member
Joined
Jul 25, 2008
Messages
697
Reaction score
6
Points
0
Because they are second hand items, Buy a new one.

And that's a load of crap, External fuel pumps are legal as long as they are mounted properly.
 

adamR

New Member
Joined
Aug 15, 2013
Messages
9
Reaction score
0
Points
0
Location
rotorua nz
Members Ride
1994 VR 5.0L
cheers

Because they are second hand items, Buy a new one.

And that's a load of crap, External fuel pumps are legal as long as they are mounted properly.
thanks for the advice,....cheers, i'm guessing as much about having to get a new pump...

as for the failed warrant, the vtnz guy said he wouldn't pass it with the custom pump because the wires were too close to the tank........???? hmm... i didn't end up taking it back to vtnz after that, it was warranted at the aa in the end.......

thanks again......
 

DavoVP

New Member
Joined
Jul 25, 2008
Messages
697
Reaction score
6
Points
0
thanks for the advice,....cheers, i'm guessing as much about having to get a new pump...

as for the failed warrant, the vtnz guy said he wouldn't pass it with the custom pump because the wires were too close to the tank........???? hmm... i didn't end up taking it back to vtnz after that, it was warranted at the aa in the end.......

thanks again......
Mate you should of called him a muppet and walked out. The stock fuel pump has +12v running directly into the tank.

To close lol thanks for the chuckle :D
 

Cheap6

New Member
Joined
Jun 19, 2005
Messages
2,498
Reaction score
73
Points
0
Members Ride
VP Exec
Maybe the concern is (was) that the wires will rub on the tank. Uninsulated 12V wires near a metal surface, near fuel, in open air, is probably not a good thing. Even though it now has a WOF, it may be worth fixing the wire anyway?

VN V8 with the 80l tank had an external pressure pump from the factory. If that is emulated you can't be too far wrong.
 

adamR

New Member
Joined
Aug 15, 2013
Messages
9
Reaction score
0
Points
0
Location
rotorua nz
Members Ride
1994 VR 5.0L
Mate you should of called him a muppet and walked out. The stock fuel pump has +12v running directly into the tank.

To close lol thanks for the chuckle :D
lol.... :D yeah i should have.... hahaha.... i didnt go back again to them.....
 

adamR

New Member
Joined
Aug 15, 2013
Messages
9
Reaction score
0
Points
0
Location
rotorua nz
Members Ride
1994 VR 5.0L
Maybe the concern is (was) that the wires will rub on the tank. Uninsulated 12V wires near a metal surface, near fuel, in open air, is probably not a good thing. Even though it now has a WOF, it may be worth fixing the wire anyway?

VN V8 with the 80l tank had an external pressure pump from the factory. If that is emulated you can't be too far wrong.
evening :D

thanks for the advice, :) i replaced the fuel pump with a cheap one..... i shouldn't have been so cheap and splashed out on a better custom one fitted by a pro :D ,,... this coming payday i'm off to get a new one.....however, it fired up nicely today, i warmed it up, reved the shet out of it, and took it for a blat..... it pulled like a champ.....,..

but still, to be safe, i will replace the fuel pump again with a brand new one, all new leads, plugs, etc, and fuel filter all at the same time.... clean the injectors, do the whole lot at once..... it's booked in for a tune then dyno and some other mods,... they will do it all at a shop here in rotorua, new rev counter, ecu mods, to get a few more kw out of her....

my wrx is in there at the moment getting the same done to it.... that's just got a rebuilt motor, 2 months old....

thanks again for the advice :)
 

adamR

New Member
Joined
Aug 15, 2013
Messages
9
Reaction score
0
Points
0
Location
rotorua nz
Members Ride
1994 VR 5.0L

bck2basics

New Member
Joined
Apr 19, 2013
Messages
47
Reaction score
0
Points
0
Age
30
Location
Melbourne
Members Ride
Vl Calais
I'm gonna take a stab in the dark and I may be completely wrong (anyone feel free to tell me I am) but could it be that due to the custom fuel pump and your memcal maybe tuned to that pump, that's why your having problems?
 
Top