Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VR calias 1993 misfire

smarty091

New Member
Joined
Mar 22, 2009
Messages
13
Reaction score
0
Points
0
Members Ride
VR Calais
hi all got a VR calais.
it misfires underload in drive, cahnged the plugs and leads but misfire still occured... swapped a coil pack off a VN but misfire was still there.

anyone got ideas of a fix for this problem??
should i try a brand new coil pack??

thanx
 

88GreenVN

Next Exit Left
Joined
Jun 12, 2006
Messages
6,793
Reaction score
131
Points
63
Age
56
Location
Surprise, Arizona
Members Ride
Dodge Ram Van 1500 5.2 V8
How old is the harmonic balancer and CAS?
 

smarty091

New Member
Joined
Mar 22, 2009
Messages
13
Reaction score
0
Points
0
Members Ride
VR Calais
the harmonic balancer was replaced bout a month ago but not sure about the crank angle sensor. checked codes today on the computer but no codes.
 

88GreenVN

Next Exit Left
Joined
Jun 12, 2006
Messages
6,793
Reaction score
131
Points
63
Age
56
Location
Surprise, Arizona
Members Ride
Dodge Ram Van 1500 5.2 V8
the harmonic balancer was replaced bout a month ago but not sure about the crank angle sensor. checked codes today on the computer but no codes.
The 3 mail things are CAS, DFI/Coils and leads for a braking down under load.

But also can be the fuel pump/regulator on the way out and not delivering enough pressure.
 

smarty091

New Member
Joined
Mar 22, 2009
Messages
13
Reaction score
0
Points
0
Members Ride
VR Calais
The 3 mail things are CAS, DFI/Coils and leads for a braking down under load.

But also can be the fuel pump/regulator on the way out and not delivering enough pressure.
ok so you reckon i should change the crank angle sensor and see how that goes??
 

Chris E

New Member
Joined
Dec 28, 2008
Messages
249
Reaction score
1
Points
0
Location
Brisbane
Members Ride
Vr Executive 3.8
My vr was doing this recently and it turned out that the alternator putting out the wrong volts was the cause of alot of problems...misfiring, stalling, gearbox going into limp mode, stereo going nuts, put another alternator in and its all good...just something to keep in mind
 
Top