Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Vr runs like junk

stevedarwin

New Member
Joined
Jan 15, 2010
Messages
1
Reaction score
0
Points
0
Members Ride
VR acclaim
Hi, feedback is appreciated. With my VR V6, recently it seems to idle a bit rough, there was a miss but it seems to have been fixed with new leads and plugs, it still idles rough when its warm and when I am braking heading toward traffic lights or whatever it sometimes stalls when almost stopped, if I place it in drive and let it coast with out touching the accel. or brakes it surges at low speed. As mentioned I changed the leads and plugs. The fuel filter has been changed, the fuel pump is quite new also. I gave it a throttle body clean today. The batt is good as is the alt almost new. I have done extensive exhaustive searches on this site and there are a million similar issues but nothing quite like mine. Please help I had this car for 12 years and all mechanical has been done by me, but this one is doing my head in!
 

wortus

Active Member
Joined
Dec 2, 2009
Messages
1,885
Reaction score
21
Points
38
Location
Sydney
Members Ride
VY Series 2 25th Anniversary in Phantom Mica
I'd be checking for any vacuum leaks and also the IAC (Idle air control valve). What did you clean the throttle body with and did you do it with the IAC and TPS attached or removed?
It's not a good idea to soak the IAC and TPS with throttler body cleaner.
 
Top