Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VR V6 won't rev

luxadore

New Member
Joined
May 5, 2009
Messages
15
Reaction score
0
Points
0
Members Ride
1994 hilux dual cab/VR V6
Hi, I have just finished installing a VR V6 and auto transmission into my hilux but am yet to fit an exhaust up to it yet, I have the engine pipes with the O2 sensor and the catalytic converter fitted but the whole set up feels like crap to drive, I test drove it around the block a few times and it feels like it doesn't want to rev, when I put my foot down it coughs and splutters like crap and when I lift my foot off I get a small blip in power and thats about it, I am using a pod air filter for now until I have a 3 inch pipe bent up to join up with the hilux air cleaner assembly
I don't have any error fault codes on the PCM so I think everything is wired up well and working ok
Would the lack of exhaust back pressure be making the vehicle behave this way?
 

camstatic

I'm back babeh.
Joined
May 19, 2006
Messages
327
Reaction score
4
Points
18
Location
Regional SA
Members Ride
VZ SS
Sounds like throttle position sensor isn't reading right... I would also theck the MAP sensor
 

VR38

Well-Known Member
Joined
Dec 23, 2008
Messages
3,078
Reaction score
27
Points
48
Members Ride
VB SL/E
Plug lead loose, vacuum leak?
 

luxadore

New Member
Joined
May 5, 2009
Messages
15
Reaction score
0
Points
0
Members Ride
1994 hilux dual cab/VR V6
Bit of an update.
I had an exhaust fitted today, just a 2 1/4" single muffler system and went for a drive it still feels crappy and hesitant to rev up under load. (past say 20% throttle)
my fault light isn't illuminated so am guessing all is well sensor wise but one thing I should tell is that when I did the coversion I had to drain my diesel fuel tank and run about 3-5 liters of unleaded through and let that drain out completely before filling the tank with ultimate 98, could there be some residue diesel or moisture in the tank mixing with the fresh fuel causing the problem?
I can get the car to cruise along at 80 in D with the torque converter locked up but anything faster than that sees the transmission drop back and stay in 3rd with no lock up and it feels like the engines working hard
 

luxadore

New Member
Joined
May 5, 2009
Messages
15
Reaction score
0
Points
0
Members Ride
1994 hilux dual cab/VR V6
I have a feeling it may be a dodgy coil pack, causing spark to break down at higher loads, I have borrowed a set to swap over and see if makes a difference
 
Top