Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VR V8 Transmission Issue

SUSS8

Member
Joined
Jan 12, 2009
Messages
222
Reaction score
1
Points
18
Location
Western Suburbs, Melb
Members Ride
'94 Holden Calais VR V8
Well I was driving the other day when I put my foot down a bit to Overtake when my car started revving out like nuts. Anyway its since been slipping in 3rd like it really struggles thru the gears but just makes it into 3rd. Im just wondering how much I would be looking at getting it fixed most likely a full rebuild. I got quoted a full rebuild stage 2 shift kit and a stall for 1850. But since I don't have the funds at this time and need my car on the road anyone know where I can go and maybe a price range. I'm also living in the western suburbs. Really need sOme helP coz I'm desperate !!!
 

The1

A Memcal a Day Keeps..
Joined
Jan 12, 2005
Messages
2,367
Reaction score
45
Points
48
Location
QLD
Website
www.eyeit.org
Members Ride
VS V6 Berlina Auto
only other way round it is pickup a cheap used box, wreckers may have one for a few hundred.
 

VrWagz1

The Wagon on Wheels..
Joined
May 5, 2008
Messages
2,438
Reaction score
29
Points
48
Location
wollongong
Website
www.wagzhome.justcommodores.com.au
Members Ride
VE SSV MY09 Auto Wagon
Rebuild kits can be had fairly cheaply online. Never done one myself, really it dosnt look to bad, but its the cheapest your gonna get a reliable box back in your car. I wouldnt be to worried about giving it ago, its kinda broken anyway and if you have the tools at home you mise well use them:) The worst bit looks like getting it in and out of the car, i think you neeed a lond extension for ur ratchet from memory for one bolt. I think theres some info floating around here aswell.
 

SUSS8

Member
Joined
Jan 12, 2009
Messages
222
Reaction score
1
Points
18
Location
Western Suburbs, Melb
Members Ride
'94 Holden Calais VR V8
I would do it myself but havent got the room to at the moment since i currently moved house.....I forgot to add when i was driving it home once i hit 80km/h the engine light come on. ive since stopped driving it and have parked it in the garage.

Wondering if anyone has any recommendations on a mechanic who can help me out with my Auto in Western Suburbs.... getting pretty desperate to fix it asap.
 

vscaprice98

New Member
Joined
Dec 12, 2010
Messages
90
Reaction score
0
Points
0
Age
41
Location
brisbane
Members Ride
vs caprice
i wouldnt go a stall unless it not stock some peoples opinions are different to others i do no the converter shop where i got my stall built to me motor says alot of people put stalls in stockos and they dont work right stalls what u got to look at well is ur usable torque off the mark to get u going if motor stock and u go straight past ur inital toque off the mark it ends up being slower off the mark all cams even standard cams having a working rev range where they start so even if u put a 2 grand stall in u find ur self going straight past ur useable torque off the spot
 

NTMAD8

New Member
Joined
May 15, 2011
Messages
2
Reaction score
0
Points
0
Location
Sunbury
Members Ride
VR HSV CAPRICE
Hi guys im new here and am sorry if im posting in the wrong area...... some of the info you guys share on here is unreal and has solved past car troubles iv had just reading what you guys have to say. prob best forum site iv seen. Ok iv got a 94 vr 5ltr caprice that i bought about a month ago with what i and the seller both thort was a damaged transmission. after removing the transmission and taking it to be rebuilt i explained the probem it was giving me to the trans bloke and he said it just sounded like a blown trans fuse and was in limp home mode, well after going home and checking the fuse he was right, i had him rebuild it anyway with a shift kit and kevlar and corvette fittings. anyways after installing the transmission after i got it back and fired it up the trans fuse kept popping and about six codes appeared all to do with the transmission.so took it to my auto elec which found the problem been to do with the steering solinoid for the vairable steering so we unplugged it and all codes had gone and fuse doesent blow anymore, took it up the street and it is still stuck in 3rd gear and wont drop back if i put the foot down and will only manually select 2nd but no codes are appearing to say anythings wrong now.... WTF. any light on the matter would be absolutlely appreciated im frazzled. thanks
 

hako

Donating Member
Joined
Aug 1, 2004
Messages
8,020
Reaction score
89
Points
48
Age
78
Location
Toowoomba SE QLD
Members Ride
VS11 BT1 V6
Maybe the ECU thinks you have problems and is switching to LHM - it will detect that the PS is disconnected. Did you reset the ECU after disconnecting the PS....if not it will still have the fault unless reset.
 

NTMAD8

New Member
Joined
May 15, 2011
Messages
2
Reaction score
0
Points
0
Location
Sunbury
Members Ride
VR HSV CAPRICE
yeh after disconnecting the ps plug, replacing the fuse and reset the ecu it shows no more codes except for the normal code 12. Also the airbag light is on aswel as the horn not workin... could that relate to the prob
 

hako

Donating Member
Joined
Aug 1, 2004
Messages
8,020
Reaction score
89
Points
48
Age
78
Location
Toowoomba SE QLD
Members Ride
VS11 BT1 V6
The airbag light and horn could be a clockspring issue - both power thru the clockspring - to remove the airbag light you must go to an auto elec as you need a scan tool to erase it but first you need to see what made it come on.....check the wiring to the horn first as maybe it's just a fuse...if it is, then the clockspring should be OK.
If you turn the ignition on when the dash or instrument panel is removed you will set an airbag light!!....hopefully that is what caused it???
 
Top