Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VS Berlina makes Creaking Noises while driving

zac_sa

Member
Joined
Dec 18, 2010
Messages
58
Reaction score
0
Points
6
Location
Adelaide
Members Ride
VE Calais
This is my 1st post ever.
Ive a VS Berlina and I lowered it with pedders springs some time back and I love how low she looks.
Anyway the problem is and I assume from it being lowered is ive stressed the steering/suspension/struts a bit.
The car when i turn and more noticably on the left side makes a creaking noise.
I took the front passenger wheel off and noticed that there is a metal shaft attached to the strut vertically. The bushes(rubber grommits) or whatever theyre called are totally off the top part of the pin and on the bottom part its absolutely split.

It looks like I need new bushes (rubbers).
Where do I get them from and as I dont know what theyre called or what the tyre/strut arms are called im not sure what to ask for.

I can post a pic up if need be.

Im also not 100% sure ive creaks coming from other parts of the car. Always happens when im turning, even a small turn.
 

db_notso

diagnostic technician...
Joined
Oct 2, 2010
Messages
979
Reaction score
7
Points
0
Age
33
Location
sunshine coast, qld
Members Ride
vt v6, mods(susp brakesetc...)
this is called your LINK PIN
it attaches the SWAY BAR to the STRUt

the parts you need are LINK PIN BUSHES
and (four?) new NUTS

the nuts stretch when fitted and should be replaced with the bushes

fault is very common and parts are readily available from holden OR you could upgrade (next to no difference in handling though they just last a little longer)
http://cgi.ebay.com.au/Commodore-He...=AU_Car_Parts_Accessories&hash=item45f7caaf19
 

zac_sa

Member
Joined
Dec 18, 2010
Messages
58
Reaction score
0
Points
6
Location
Adelaide
Members Ride
VE Calais
Thanks heaps for that,
That looks exactly like what I need :)
I hope theyre easy to replace and hopefully that gets rid of the creaking noises.
Im looking to sell the VS soon to get a VE Calais.
 

zac_sa

Member
Joined
Dec 18, 2010
Messages
58
Reaction score
0
Points
6
Location
Adelaide
Members Ride
VE Calais

cander24

New Member
Joined
Aug 26, 2008
Messages
992
Reaction score
9
Points
0
Location
NSW South Coast
Members Ride
VZ GTO. VS LS1.
I noticed on the VS that the pins are straight where as these are slightly bent but I guess its all the same.
Yep that's fine. Different brands are slightly different. Genuine to suit vs is straight whereas many of the aftermarket replacements (particularly the heavy duty) have slightly bent and offset ends. Work just the same.

With the Urethane bushes is there anything I need to know re tightening them up??
The urethane bushes tighten up just the same as the standard rubber bushes, keeping the big/small end of the bush and the metal discs in the same sequence. Tighten until the nut locks up when it runs out of thread on the rod. Since the link rod will try to spin as you tighten the nut, I just put a set of locking pliers onto the rod to stop this. Some link rods will have a 10mm form on them so you can also put a spanner onto them.

Also are there any things I need to look out for, ie once I take the old pin out is it easy enough to put the new pin in?
Basically, installation is the reverse of removal. To get the rods out/in, you'll need to have the steering on full lock and flex the front swaybar down with a good prybar. I do this with a prybar under the k frame (engine cross member) and lever down on the swaybar. Don't be afraid to use some force as some of them can be a real pr#ck (particularly the genuine rods without the kinked ends).

Also, it's hard to say without actually seeing it, but there's also a good chance your noise could be your top strut bearings from your description of when/how it happens. If your new link rods and rubbers don't get rid of your creaking, this is what i'd be looking at next. They're about $15 each from memory.
Cheers,
Chris.
 

zac_sa

Member
Joined
Dec 18, 2010
Messages
58
Reaction score
0
Points
6
Location
Adelaide
Members Ride
VE Calais
Thanks so much for your help, I really appreciate it.
 

db_notso

diagnostic technician...
Joined
Oct 2, 2010
Messages
979
Reaction score
7
Points
0
Age
33
Location
sunshine coast, qld
Members Ride
vt v6, mods(susp brakesetc...)
above 100% correct

the strut top mount bearings OR bearing plate get old and wear out they allow the strut to pivot on the front weight of the car allowing steering
to remove you need spring compressors and a carton and patience a novice would be best to replace the BUSH (top bush bearing sits in aswell)
but sounds like its just the link pins~!
 

zac_sa

Member
Joined
Dec 18, 2010
Messages
58
Reaction score
0
Points
6
Location
Adelaide
Members Ride
VE Calais
Ok, this afternoon my link pins arrived in the post, so I was keen to tackle this and replace the severly worn pin/bushes.
It wasnt as straight forward as I thought. I jacked up one side and removed the nuts eventually. I couldnt get my damn socket in due to the lack of clearance to get the socket over the nut.
So ring spanner and limited to 1/3 turn it was.
When I got the nuts off I had dramas with the sway bar not being able to slip off. I quickly did a search on the forum and while theres no real answer it seemed to be the easy way to remove the other side. You dont want to know how I got the whole front end of the car up since ive only got 1 Jack.
Anyway taking off the lower nut on the link pin from the other side helped give the sway bar some slack to get it off the old link pin and slide the new one in.
Due to the sun going down ive not yet secured the 1st link pin in and will do it tomorrow.

What I want to know is how tight do I do the nuts? ive the blue urethane bushes. How much should I compress or make them bulge?
 

db_notso

diagnostic technician...
Joined
Oct 2, 2010
Messages
979
Reaction score
7
Points
0
Age
33
Location
sunshine coast, qld
Members Ride
vt v6, mods(susp brakesetc...)
only need to be tight enough to not come loose
so lets say like a spark plug?

oh fyi start all the nuts before you do any of them up (word of advice here)
 

zac_sa

Member
Joined
Dec 18, 2010
Messages
58
Reaction score
0
Points
6
Location
Adelaide
Members Ride
VE Calais
I guess I did the nuts up too tight, I noticed the bushes and mainly on the ones that attach to the sway bar were becoming deformed. I loosened them up. Ive not dealt with Urethane bushes before but anyway I think I screwed them up as now they are in a weird shape.
I can see that they may sheer off now as they wont go back to their desired shape.
I just hope it lasts a month or so before it needs to get jacked up again.

Oh the ringing noise is now gone but the creaking is still there. Only seems to be right hand turns. So the strut top bushes/bearings need doing too I suppose.
 
Top