Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VS has trouble with revs

whitevanman

New Member
Joined
Dec 25, 2005
Messages
12
Reaction score
0
Points
0
Age
67
Members Ride
VN 5.0
Had a look through the other threads but was unable to see anything similar to the problem at hand.
My wife's VS developed a problem where the V6 dicided it didn't want to rev past about 3 or 4,000 RPM, would start to break down something like the timing not advancing properly.
Trial and error time I thought so I changed the coil pack with no change, changed the spark leads with no change,changed the throttle body with switches attached with no change,changed the MAF sensor with no change, swapped computer boxes with no change,changed the crankshaft positioning sensor as well as the camshaft positioning sensor with no change, changed the fuel filter while I was on the job but that did nothing,I have changed every electrical componant that I can see or find without it making any difference to what is happening.
Can anybody shed any light on what might be the problem?
The next step I guess is to change the injectors but with it running very nicely up to these revs I was not convinced the injectors would be at fault, stranger things have happened!!!!!
 

Tree cutter

Tree cutter
Joined
Apr 15, 2006
Messages
1,020
Reaction score
8
Points
38
Location
Mt Gambier SA
Members Ride
VX Calais SuperchargedV6
Could be a blocked cat converter, have heard this will stop an engine revving.
 

hako

Donating Member
Joined
Aug 1, 2004
Messages
8,020
Reaction score
87
Points
48
Age
77
Location
Toowoomba SE QLD
Members Ride
VS11 BT1 V6
Or the fuel pump pickup strainer in the fuel tank...could be water there partially blocking the supply...though my first thought would be the same as Tree cutter...blocked cat.
 
Top