Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VS S Pack Ute - LSD Not working?

Joined
Mar 5, 2007
Messages
269
Reaction score
9
Points
0
Age
31
Location
Cairns, QLD
Members Ride
VS S Pack Ute
Ok I have an S pack ute and the LSD doesn't seem to be working? The diff cover has the appropriate tag etc.

What can cause this?

I am aware of only the following possibilities:
- old, crappy oil in diff fouling it
- clutch packs too worn

Are there any other possibilities and what potential fixes are there?

Thanks.
 

NeilB

New Member
Joined
Dec 5, 2005
Messages
400
Reaction score
3
Points
0
Age
62
Members Ride
VR Caprice
Its quite common for the LSD centre to crack and send it to single spinner. ift the back of the car up and turn 1 wheel if the other side turns the same way at the same speed your LSD is good. It may need a good service I have been quoted $650 for a full rebuild her at Taree.
 

NeilB

New Member
Joined
Dec 5, 2005
Messages
400
Reaction score
3
Points
0
Age
62
Members Ride
VR Caprice
Its a bit more than that as if you dont shim them properly you can do heaps of damage, you also need to remove the axles so you need a slide hammer. I would say if you havnt done this before oe dont have a really good understanding of the process get the pros to do it.
There may be more damage than the cones.
 
Top