Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Vs ute instrument cluster swap?

Lukeyd

New Member
Joined
Mar 3, 2019
Messages
3
Reaction score
0
Points
1
Age
35
Location
Vic
Members Ride
Vs
Hi all, my old man has a vs Olympic edition ute the odometer stopped working so he just brought another full instrument cluster from the wreckers. He has fitted it and everything works except the cruse control now. The light comes on the dash but it won't set the cruise. Has anyone delt or herd of a issue like this before??

Thanks Luke.
 

vs-lover

Well-Known Member
Joined
Mar 9, 2013
Messages
2,443
Reaction score
1,590
Points
113
Location
Adelaide
Members Ride
VS S2 Calais, VS S2 Exec Wagon, VS S2 Acclaim
Honestly why would you go down that path when you can simply replace your "Sun gear set" in the Speedometer and retain the original cluster and accurate Odometer ???
 

Lukeyd

New Member
Joined
Mar 3, 2019
Messages
3
Reaction score
0
Points
1
Age
35
Location
Vic
Members Ride
Vs
Thanks mate. I wish he did but he through away the original cluster so we can't do that now.
 

vs-lover

Well-Known Member
Joined
Mar 9, 2013
Messages
2,443
Reaction score
1,590
Points
113
Location
Adelaide
Members Ride
VS S2 Calais, VS S2 Exec Wagon, VS S2 Acclaim
wow !
 

wildfiremaint

Active Member
Joined
Jan 3, 2006
Messages
272
Reaction score
119
Points
43
Location
Sydney
Members Ride
VR SS , 2007 Subaru LIBERTY Wagon
Ive heard of decluttering.
That must be declustering.:cool:

Maybe the switch at the brake pedal has been disturbed or has gone faulty.
 
Last edited:

Lukeyd

New Member
Joined
Mar 3, 2019
Messages
3
Reaction score
0
Points
1
Age
35
Location
Vic
Members Ride
Vs
Lol yes a big mistake. We have checked the switch at the brake pedal and all is fine. We have power a 3 pins on the cruise motor under the bonnet with ignition on and cruse turned on.
It's there may have been something in the other dash that made the cruise lock on but they all look exactly the same.
 

Dj1crook

New Member
Joined
Sep 14, 2017
Messages
6
Reaction score
0
Points
1
Age
29
Location
Adelaide
Members Ride
1994 VR Commodore/Lexcen, 1992 Holden Nova Hatch
check the brake lights to see if any are blown
 

losh1971

Well-Known Member
Joined
Jan 17, 2010
Messages
13,310
Reaction score
6,551
Points
113
Location
North Tas
Members Ride
VE Series I SS Ute
There are two pedal switches for the cruise the other be could be faulty, as is quite common.
 
Top