Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VS V6 Thermo issues.

Adrian L.

Member
Joined
Feb 24, 2013
Messages
53
Reaction score
0
Points
6
Location
Melbourne
Members Ride
1983 VH SL Sedan
Hi Guy's I am having an issue with the VS V6 I own. All of a sudden one day the thermo just stopped working. I done some research and it said to unplug the Temperature sender for the ECM and within 6 seconds the thermo should go into first stage and then after a further 6 seconds into second stage, After I un plugged it it just went into second stage (full on) ?. I used a strong heavy duty radiator cleaner for a couple of days, replaced the thermostat, both temp senders radiator, and radiator cap and flushed the radiator 5 times but nothing. the thermo still does not engage, if I turn the A/C on the fan comes on. I tried replacing the high and low thermo relays but still no difference. I am thinking of opening the kick panel on the PAX side and removing the ECM and seeing if the (Pin 6) has fried itself, Thats all I have read that could be possibly wrong ?

The thermo use to come on at no more than 1/3 and never exceed half EVER but now it will just go over the H if you let it ( I had it at the H once).
Also the system seems to have a lot of pressure in it. I am thinking maybe it has a head problem but I knew this before this thermo problem and I don't want to rebuild the engine until I have the thermo sorted out.

Any advice would be greatly appreciated.

Regards
Adrian
 

someguy360

Well-Known Member
Joined
Jan 29, 2011
Messages
2,781
Reaction score
1,679
Points
113
Location
SA
Members Ride
94' VR Caprice 304 - 12' VE Thunder Ute
Have you completely bled the cooling system with the heater on?

9 out of 10 times that a V6 cooling issue remains after replacing these parts is due to air being trapped in the system.

Is the oil dipstick milky?

Is there any sludge on the radiator cap/overflow tank?
 

Adrian L.

Member
Joined
Feb 24, 2013
Messages
53
Reaction score
0
Points
6
Location
Melbourne
Members Ride
1983 VH SL Sedan
Hi Someguy, thanks for the reply. I did bleed the radiator with the heater on, I am 100% all air is out. the dipstick and cap are not milky, The oil looks a slight used brown like any 10,000Klm oil should. This has me stumped.
 

RX25SE

Real cars are steel cars.
Joined
Jan 20, 2009
Messages
1,260
Reaction score
10
Points
38
Location
Melbourne
Members Ride
MY07 Liberty 30R Spec B 6sp wagon
Sounds like an electrical issue, not cooling system.

Will the fans come on if you let it idle with the a/c off?

If it does, the earth the the low speed fan may be dodgy.
There is an earth point near the battery on the inner guard. Remove all the terminals, clean them and make sure the mounting stud is clean and tight (from memory its just a bolt, its head is in the wheel arch).
 

Adrian L.

Member
Joined
Feb 24, 2013
Messages
53
Reaction score
0
Points
6
Location
Melbourne
Members Ride
1983 VH SL Sedan
Hi RX, No the fans will not come on at all, I will have a look at the Earth lead tomorrow after work. I hope its the problem, Does this earth supply the LOW relay ?
 

RX25SE

Real cars are steel cars.
Joined
Jan 20, 2009
Messages
1,260
Reaction score
10
Points
38
Location
Melbourne
Members Ride
MY07 Liberty 30R Spec B 6sp wagon
I think so.
It's been a while since I did one and I've sold my VS.

Normally that earth fault does not prevent the hi fan coming on when the engine temp rises.

If you have access to a scan tool, the live data will tell you if the coolant sensor is reading OK as it displays it in degC.

brettjjj has wiring diagrams.
 

Adrian L.

Member
Joined
Feb 24, 2013
Messages
53
Reaction score
0
Points
6
Location
Melbourne
Members Ride
1983 VH SL Sedan
Sorry guys was late last night. The thermo comes on if the A/C is turned on.
 

Cpt Awesome

Member
Joined
Jul 4, 2010
Messages
134
Reaction score
1
Points
18
Location
perth wa
Members Ride
04 S II HBD VY SS , 04 VY S II Executive
The low fan is switched purely by the BCM and the ecu/PCM switches the high fan. So I reckon it'll be either of those two. About $50 for another ecu and about $150 for a new BCM and key head
 

Adrian L.

Member
Joined
Feb 24, 2013
Messages
53
Reaction score
0
Points
6
Location
Melbourne
Members Ride
1983 VH SL Sedan
OK I have a BCM as the Remote did not work on the key, I hated not being able to open the doors with the remote changed it over 12 months ago. I just hooked it up and let the car cook itself, so its not the BCM. I removed the PCM and dismantled it (I did read somewhere on here that the inside can burn out on the fan pin but everything looked ok in there, (but just because it looks ok does not mean it is) I will get a hold of another PCM during the week short of that its off to the auto elec. Will my PCM from my 1994 VR V6 fit my 1997 VS V6 ? If so I might swap it over saves buying a PCM if its not the problem !!!

Thanks Guy's.
 

Cheap6

New Member
Joined
Jun 19, 2005
Messages
2,498
Reaction score
74
Points
0
Members Ride
VP Exec
No, the VR and VS PCM's won't interchange.
 
Top