Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Vt loses power uphil. HELP

Finnrizell

New Member
Joined
Jan 7, 2011
Messages
11
Reaction score
0
Points
0
Age
36
Location
Mandurah
Members Ride
VT Executive
My vt it like sputters and jerks round wen ya doin between 80 n 100 and wen ya hit a incline it happens strait away. Ya can sit on 100 and Ito be good than just sputters for a bit than good again. Wen take ya foot off the accelerator than go to give it to it again it does it straight away?? Real weird cupple other posts sayin tha exact same thing on ere but no answers umm iv changed the fuel filter the oil filter MAF plugs leads coil packs and module and itstill doin it ane1no anything???
 

lout

Well-Known Member
Joined
May 13, 2006
Messages
2,935
Reaction score
583
Points
113
Location
Langwarrin Victoria
Members Ride
VX Executive S2
fuel pump?
 

Finnrizell

New Member
Joined
Jan 7, 2011
Messages
11
Reaction score
0
Points
0
Age
36
Location
Mandurah
Members Ride
VT Executive
I will let u no wen I'm nearlly empty I havnt noticed it yet. It really doesn't do it much wen ya doin under 60 even on a hill. But wen ur doin 90 to 100 any movement in yr accelerator makes it jump around and wen ya ya hit an incline
 

Cúl-Báire

New Member
Joined
Dec 27, 2008
Messages
244
Reaction score
3
Points
0
Location
Brisbane, QLD
Members Ride
AUII XR8 Ute & BAII XR6
Sounds to me like your fuel pump is ####ed!
 

Finnrizell

New Member
Joined
Jan 7, 2011
Messages
11
Reaction score
0
Points
0
Age
36
Location
Mandurah
Members Ride
VT Executive
My fuel pummp went bout two yrs ago put a new one in than. Wen it went that time it was in a instant no signs like this. Do u no if they f#*k around like this at all showin signs of goin??
 

MkyHnly

New Member
Joined
Jun 28, 2009
Messages
150
Reaction score
0
Points
0
Location
Croydon, VIC
Members Ride
VC SL/E 253 Project - BMW 328i Coupe Daily
im having the same issues and i know that my fuel pump needs replacing... when i go hard right around a corner my car stalls. this could also be contributing to the spluttering issues that i have when going hard on power? cheers
 

Finnrizell

New Member
Joined
Jan 7, 2011
Messages
11
Reaction score
0
Points
0
Age
36
Location
Mandurah
Members Ride
VT Executive
Hey

Hey mate I put in a 13 dollar bottle of fuel injector cleaner into a empty tank than filled up wit vortex 98 that was last nite .I've driven it 4 times since and it has felt remarkably better each drive. Try that and see how it goes I'm convinced it's either injectors or pump mine isn't stallin at all tho so we could ave diffrent problems but yeah even on hills mine is runnin alot better sputters a bit but seems to get thru it lot quiker hopin it only gets better wit each drive I will keep ya posted mate!!
 

scotty125

New Member
Joined
Jan 5, 2011
Messages
8
Reaction score
0
Points
0
Location
hunter valley
Members Ride
2000 vt
if automatic it could be your torque converter if so goto a transmission specialist or it could just be your fuel pump
 
Top