Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Vt popping under load

Pumba83

New Member
Joined
Oct 1, 2012
Messages
142
Reaction score
1
Points
0
Age
37
Location
Bunbury
Members Ride
1998 vt s-pack supercharged
Hi all

My wife ran my fuel tank dry on my cammed s/c v6 and now the engine pops under load. I've replaced the fuel filter and the fuel pump still sounds like its working when the accessories are on.

Any ideas?
 

accentstencil

Well-Known Member
Joined
Jun 30, 2005
Messages
8,170
Reaction score
376
Points
83
Age
68
Location
Eschol Park, Sydney
Members Ride
WH II Caprice, 5.7 2017 Captiva.
I'm not quite sure what you mean by popping, if you mean misfiring then I would look at spark plugs and leads. Whenever I have developed a miss it has always been a faulty lead. If you haven't changed your leads in a long time it might be time to do so.
 

Pumba83

New Member
Joined
Oct 1, 2012
Messages
142
Reaction score
1
Points
0
Age
37
Location
Bunbury
Members Ride
1998 vt s-pack supercharged
Nah it has all new plugs set to 0.8mm gap and 10mm top gun leads all brand new. The mrs ran the tank dry last week and the surging/popping started after that. I think as the engine is still being run in something along the fuel line side of things is not coping possibly the fuel regulator on the fuel rail, I've replaced the fuel filter and listened for the fuel pump to come on once the key is at accessories. I think my best bet might be to put a fuel pressure guage on it to make sure it's receiving at least 52 psi.
 

Pumba83

New Member
Joined
Oct 1, 2012
Messages
142
Reaction score
1
Points
0
Age
37
Location
Bunbury
Members Ride
1998 vt s-pack supercharged
Sorted .... It failed fuel pressure test today so fuel pump is buggered
 
Top