Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VT V6 - Throttle flat spot, is it crank angle sensor or fuel blockage

ConradJohns

New Member
Joined
Jun 1, 2024
Messages
1
Reaction score
0
Points
1
Age
41
Location
Lyrup
Members Ride
Holden Commodore 1998 VT berlina
My beast has been sitting in shed. When I put it away it was on empty. Now I got it out and started it has a massive flat spot in throttle, but if I slowly push accelerator slowly it will rev up. It’s like it’s starved of fuel supply. Any help and direction would be appreciated
 

Lex

Well-Known Member
Joined
Sep 19, 2012
Messages
6,212
Reaction score
5,683
Points
113
Location
Geelong Victoria
Members Ride
VT Executive S1 V6 6 speed Auto Wagon
My beast has been sitting in shed. When I put it away it was on empty. Now I got it out and started it has a massive flat spot in throttle, but if I slowly push accelerator slowly it will rev up. It’s like it’s starved of fuel supply. Any help and direction would be appreciated
Silly question, have you added fresh fuel?
 

losh1971

Well-Known Member
Joined
Jan 17, 2010
Messages
23,170
Reaction score
23,329
Points
113
Location
North Tas
Members Ride
VE Series I SS Ute
One thing I'm pretty confident it's not is the CAS.
 

Immortality

Can't live without smoky bacon!
Staff member
Joined
Apr 15, 2006
Messages
22,891
Reaction score
21,263
Points
113
Location
Sth Auck, NZ
Members Ride
HSV VS Senator, VX Calais II L67
Throw in some injector cleaner and new fuel.
 

VSYoot

Active Member
Joined
May 4, 2022
Messages
59
Reaction score
201
Points
33
Age
41
Location
Near Avoca Vic
Members Ride
VS Ute/VP Berlina. Caring for a 597kW VE SS
Had similar syptoms with a dicky plug on the side of the coil packs
 

vxcalais_01

Well-Known Member
Joined
Jul 18, 2006
Messages
1,362
Reaction score
46
Points
48
Location
Melbourne
Members Ride
VX V6 Calais 3.8 2001
DFI Module fault or coil can do it sometimes. As others recommended, trying some fuel system cleaner is a good start. But the only ones worth using now are Liqui Moly in the Gold Can and the Penrite one for EGR Cat convertors etc. When you use them you will know why they actually work....they are borderline chemical weapons. Caltex used to have the best one for many years before these came along, not sure if still available.
 
  • Like
Reactions: Lex

trel

Active Member
Joined
Mar 18, 2021
Messages
207
Reaction score
161
Points
43
Age
42
Location
Victoria, Bundoora
Members Ride
2002 VXII Equipe Wagon
I can attest to the Penrite cleaner, our Mazda started getting the sulfur/rotten egg smell, possibly blocked/defective cat.

Ran a bottle of the Penrite through it before a trip to Ballarat with fresh fuel, haven't had a problem since. Engine revving smoother, and it's quietened the exhaust down a little.
 
  • Like
Reactions: Lex
Top