Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VX horn and steering wheel controls not working- intermittent problem

damo_

New Member
Joined
Nov 17, 2009
Messages
5
Reaction score
0
Points
0
Members Ride
VX Berlina LS1, VX Acclaim Wag
Hi all, have tryed the search function and just after more advice

Recently purchased VX acclaim wagon, horn and s/w controls not working, took fuse out to check saw it was OK so was replaced, both started working. Next time I went to drive car not working again. While replacing manifold gasket, battery was disconnected overnight, on reconnection started to work again, but as before only until next drive ?????

Could this be a faulty clock spring???? (no light on dash) or possibly something else ????(airbag module) Is there testing procedure for these things?

I have a Ellery workshop manual which I can"t find anything about this

Any help would be much appreciated
 

accentstencil

Well-Known Member
Joined
Jun 30, 2005
Messages
8,303
Reaction score
490
Points
83
Age
69
Location
Eschol Park, Sydney
Members Ride
WH II Caprice, 5.7 2018 Equinox LTZ V
Clock spring was the first thing that came to mind after reading your title, but I can't be sure about that.
 

ben315vz

Donating Member
Joined
May 11, 2011
Messages
1,466
Reaction score
19
Points
38
Age
30
Location
Tamborine Mountain, QLD
Members Ride
'05 Holden VZ Calais V8
Hey guys,

I done a search and found this thread and was wondering if anyone else has had this problem.

One of my cousins has given me their car for the weekend to replace the brakes, service the transmission, etc. It's a 2001 VX Executive and the steering wheel controls for the radio stop working intermittently. They told me about the problem a while ago but I never found the problem, so I was wondering if anyone else has had this happen to them, and knows how to fix it?

I can't honestly say if the horn is working or not as I haven't tried it.

Cheers,
Ben.
 
Last edited:

ben315vz

Donating Member
Joined
May 11, 2011
Messages
1,466
Reaction score
19
Points
38
Age
30
Location
Tamborine Mountain, QLD
Members Ride
'05 Holden VZ Calais V8
Hey guys, horn works but steering wheel controls don't. Airbag light is NOT on, so I don't think its the clock spring. Any thoughts?
 

accentstencil

Well-Known Member
Joined
Jun 30, 2005
Messages
8,303
Reaction score
490
Points
83
Age
69
Location
Eschol Park, Sydney
Members Ride
WH II Caprice, 5.7 2018 Equinox LTZ V
Hey guys, horn works but steering wheel controls don't. Airbag light is NOT on, so I don't think its the clock spring. Any thoughts?
It could still be the clock spring because there are three separate wire ribbon type things in there, one for the air bag, one for the horn and one for the controls.
 

ben315vz

Donating Member
Joined
May 11, 2011
Messages
1,466
Reaction score
19
Points
38
Age
30
Location
Tamborine Mountain, QLD
Members Ride
'05 Holden VZ Calais V8
It could still be the clock spring because there are three separate wire ribbon type things in there, one for the air bag, one for the horn and one for the controls.

Oh ok, I just went out and tested all the fuses and they were all ok. I'll just tell them that if they want them working again they will probably have to get the clock spring replaced. I probably wont do that myself. I took my VS Berlina to a Holden dealer to have the clock spring replaced as I didn't want to risk setting off the airbag.
 

accentstencil

Well-Known Member
Joined
Jun 30, 2005
Messages
8,303
Reaction score
490
Points
83
Age
69
Location
Eschol Park, Sydney
Members Ride
WH II Caprice, 5.7 2018 Equinox LTZ V
Oh ok, I just went out and tested all the fuses and they were all ok. I'll just tell them that if they want them working again they will probably have to get the clock spring replaced. I probably wont do that myself. I took my VS Berlina to a Holden dealer to have the clock spring replaced as I didn't want to risk setting off the airbag.
I am not saying that it is the clock spring just that it is a possibility. If you disconnect the battery before removing the clock spring it will eliminate an accidental deployment of the air bag and the air bag warning light.
 

ben315vz

Donating Member
Joined
May 11, 2011
Messages
1,466
Reaction score
19
Points
38
Age
30
Location
Tamborine Mountain, QLD
Members Ride
'05 Holden VZ Calais V8
I am not saying that it is the clock spring just that it is a possibility. If you disconnect the battery before removing the clock spring it will eliminate an accidental deployment of the air bag and the air bag warning light.

lol yeah I know you not saying that its definitely the clock spring. I can't think of anything else that it could be, unless they get an auto elec to take a look... Oh well, its up to them which way they want to go about it.
 

Paul73

New Member
Joined
Apr 22, 2008
Messages
16
Reaction score
2
Points
3
Location
Perth
Members Ride
VU S2 Storm
I had the same problem with my vu. Steering wheel controls didn't work, but the horn did work and the airbag light wasn't on. Brought another clock spring from wrecker and all good. Just make sure the one you buy hasn't had the airbag deployed or it wont work.
 

028

Member
Joined
Nov 26, 2010
Messages
112
Reaction score
0
Points
16
Location
Adelaide
Members Ride
VX2
I had the same problem with my vu. Steering wheel controls didn't work, but the horn did work and the airbag light wasn't on. Brought another clock spring from wrecker and all good. Just make sure the one you buy hasn't had the airbag deployed or it wont work.

same problem here,steering wheel control not working,horn works airbag light not on,
replaced with 2nd hand clock spring,but nothing changed.
 
Top