Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

vx ss problems

Discussion in 'VT - VX Holden Commodore (1997 - 2002)' started by Jayking851, Dec 15, 2013.

  1. Jayking851

    Jayking851 New Member

    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Dec 15, 2013
    Location:
    Perth
    Members Ride:
    2001 vx ss
    hey,
    i have a 01 vx ss and it has some electrical problems.
    they include
    -thermo fans not working
    -temp gauge not working
    -fuel gauge reading incorrectly
    -aircon fans not working
    - various dash light stuck on (airbags, oil)
    - not sure if PWR and traction control work because the lights don't come on.

    i had some one come out with a tech 2 and play around with it and couldn't find the fault. they suggested it could be the ECM but i replaced it and it fixed nothing… same problems.

    does anyone know what it could be or have any suggestions on how to fix it?

    thanks in advance.
     
  2. muzza

    muzza New Member

    Messages:
    306
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Aug 3, 2005
    Location:
    gladstone
    Members Ride:
    vx berlina
    mine did very similar things as yours turns out it was my abs module , as they age the soldering inside the module breaks off the board , the reason a dodgy abs module makes your dash lights come on and aircon not work (mine blew warm air) is apparently a heap of the cars electrical wires share a path as your abs module does basically , anyway was very easy to change i tracked down a rebuilt abs module of a guy on ebay who resolders all the internals
     
  3. accentstencil

    accentstencil Well-Known Member

    Messages:
    7,731
    Likes Received:
    202
    Trophy Points:
    63
    Joined:
    Jun 30, 2005
    Location:
    Eschol Park, Sydney
    Members Ride:
    WH II Caprice, 5.7
    Could be a faulty ABS module, disconnect the electrical plug from the ABS module and see if any of the problems go away.
     
  4. st3r3otyp3

    st3r3otyp3 Donating Member

    Messages:
    2,000
    Likes Received:
    13
    Trophy Points:
    38
    Joined:
    Feb 13, 2008
    Location:
    WA bruz
    Members Ride:
    VX HSV VX SS
  5. muzza

    muzza New Member

    Messages:
    306
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Aug 3, 2005
    Location:
    gladstone
    Members Ride:
    vx berlina
  6. RUN41T

    RUN41T Go forth and modify

    Messages:
    138
    Likes Received:
    3
    Trophy Points:
    18
    Joined:
    Jun 3, 2006
    Location:
    Wollongong
    Members Ride:
    79 Vb Sle
    Same issue with my ex Ss, Unplug abs module, everything will check out ok and you will just have an abs fault...

    Swapped it out with a used one from a wrecker ($100) and now running like a champ
     
  7. Jayking851

    Jayking851 New Member

    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Dec 15, 2013
    Location:
    Perth
    Members Ride:
    2001 vx ss
    thanks guys, big help it worked out to be the abs, so it looks like I'm off to the wreckers tomorrow.
    cheers everyone, saved me from taking it to a electrician and costing me $$$
     
  8. Jayking851

    Jayking851 New Member

    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Dec 15, 2013
    Location:
    Perth
    Members Ride:
    2001 vx ss
    i have another question!
    will a vy module fit my vx? and does it matter is its manual and mines auto?
    cheers
     
  9. mpower

    mpower Well-Known Member

    Messages:
    3,200
    Likes Received:
    232
    Trophy Points:
    63
    Joined:
    Jan 22, 2007
    Location:
    Brisbane
    Members Ride:
    V2 CV8 Monaro and VXII Clubsport
    All you have to do is match the last numbers on the label (the Bosch one on the bottom when you remove the module) - the VY takes a different one, VX modules are getting harder to find.

    My 02 Clubsport and Monaro (both auto) will take either the 389 or 486 they do not work correctly with a 590 which is from a VY - the TRAC OFF light stays lit with a 590 installed.

    Hope that helps.

    I bought mine off ebay, you can get them for under $200.
     
  10. Jayking851

    Jayking851 New Member

    Messages:
    13
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Dec 15, 2013
    Location:
    Perth
    Members Ride:
    2001 vx ss
    alright cheers i knew i had to match the numbers, i will just buy one off ebay
    Cheers
     
  11. Towcar

    Towcar Well-Known Member

    Messages:
    1,069
    Likes Received:
    33
    Trophy Points:
    48
    Joined:
    Oct 8, 2013
    Location:
    Auckland NZ
    Members Ride:
    VX Berlina Wagon
    I read this yesterday and didn't think much of it, until I drove home and my dash stopped working, showing the ABS and battery light and the over all km's. I took it back and the dealer cant look at it until after xmas now, which I think they are trying to wait until it is out of warranty, anyway when I got to work I thought I would see what the engineering mode showed, interestingly it shows voltage spiking quite badly, upto 16V with about 3,000rpm. I think I may actually have a faulty voltage regulator, off to the auto electritian I go!
     
  12. accentstencil

    accentstencil Well-Known Member

    Messages:
    7,731
    Likes Received:
    202
    Trophy Points:
    63
    Joined:
    Jun 30, 2005
    Location:
    Eschol Park, Sydney
    Members Ride:
    WH II Caprice, 5.7
    You definitely have a faulty voltage regulator.
     
  13. Towcar

    Towcar Well-Known Member

    Messages:
    1,069
    Likes Received:
    33
    Trophy Points:
    48
    Joined:
    Oct 8, 2013
    Location:
    Auckland NZ
    Members Ride:
    VX Berlina Wagon
    Hopefully not a completely farked alternator to go with it! It has however toasted the battery.
     
  14. goldiloxv8

    goldiloxv8 New Member

    Messages:
    4
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Jun 6, 2012
    Location:
    melbourne 3107
    Members Ride:
    VX ser 2 SS v8 auto
    I have a VX2 SS and the traction light would come on if I had a blown light globe (tail / brake light usually). For some reason the broken globe feeds back and upsets the traction control. So look for that as a partial fix.
     
  15. Towcar

    Towcar Well-Known Member

    Messages:
    1,069
    Likes Received:
    33
    Trophy Points:
    48
    Joined:
    Oct 8, 2013
    Location:
    Auckland NZ
    Members Ride:
    VX Berlina Wagon
    Toasted alternator and battery! Merry xmas to me!
     

Share This Page