Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

vy bcm problems

loose-e-goose

New Member
Joined
Jan 27, 2011
Messages
3
Reaction score
0
Points
0
Age
31
Location
pinjarra
Members Ride
VY SS, VX Blown V6
i recently installed a new stereo in my vy n was all working fine, i had to remove the headunit to run more cables and wen i pushed the head unit back into the dash n it pinch the power cable and blew the stereo fuse, i replaced the fuse and the stereo worked again but wen the key is switched to ignition or started im gettin alot of interference through the speakers, also a lot of my electrics r playin up the following do not work, my windscreen wipers, a/c, cruise control, traction control button, indicators, reverse lights. the following does work, headlights, power windows, brake lights, central locking, also my thermo fan turn on randomly, and the car sometimes wont start with the acc and ignition relays in but will start and drive fine when they are removed, ive been told i could of fried the bcm but am not 100 % sure. any help would be great thanks
 

caaf

Member
Joined
May 11, 2009
Messages
561
Reaction score
12
Points
18
Location
Melb, Vic
Website
www.aurfscan.com.au
Members Ride
VYII Equipe S/wagon V6
Certainly sounds like voltage injection to the BCM. It may have even gone further.. You need a proficient Auto Electrician to work on that I'm guessing.
 

esca_ByDesign

Clean and Classy
Joined
Jun 2, 2009
Messages
219
Reaction score
1
Points
0
Location
Croydon Hills
Members Ride
VY exec By Design
hey mate i had kinda the same thing happen with my VY. a fuse blew, replaced that and all my lights and accesories were playing up, some on when off some off when on, some never on and some normal lol.

i spent hours trying to follow wires to see if something was fried but those cars have heaps of safety stuff so you dont blow the BCM ( i found out after from the auto elec).

i took it to an auto elec and he said the back feed from what i was adding on (crossed over wires from LED footwell neons lol) was so big it half blew anouther fuse, so it was blown but was still touching, not enough to power everthing but enough to play around and piss me off lol. he basically pulled out every fuse and checked them cause it was labelled airbag or something.

try that, i know it took the guy like 2 hours to pull out all fuses and check lol but its probly worth it before you start paying big bucks for new BCM's
 

JDJD23

New Member
Joined
Sep 13, 2012
Messages
18
Reaction score
1
Points
0
Age
27
Location
Perth
Members Ride
Vu HSV R8 Maloo
I had a Vy ss come into work with the same symptoms turned out the guy replaced one of the radiator relays with the wrong one feeding power to the BCM witch fried it. ??
 
Top