Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VY Berlina V6 Rev and idle rough

Goolz96

New Member
Joined
Aug 14, 2018
Messages
20
Reaction score
0
Points
1
Age
25
Location
Gippsland
Members Ride
VY Berlina S2
Back again. The car is idling rough and revving rough.
VY Berlina series 2, V6 Auto, petrol

When stationary in Drive, it idles at about 1500-2000rpm and essentially takes off on its own, even on small slopes.
When in Park, it idles at 2000-2500rpm.
Revs don’t drop much when slowing down.
Gears shift roughly.
The ‘check engine’ light has come on 3-4 times within about half an hour.

Been told the possible following:
Throttle position sensor (TPS)
Idle air control (IAC) valve
Dirty MAF sensor

Could it be anything else? Or has anyone experienced this before?

The car had an engine swap done about a month and a half ago. Has a VT engine with roughly 185xxx on it. Oil and coolant are fine. Not missing at all. Gearbox has around 307,600. Only been doing it the past week.
 

evBenji

Well-Known Member
Joined
Dec 22, 2010
Messages
1,104
Reaction score
70
Points
48
Location
Adelaide
Members Ride
VY Commodore
1st step would be to clean out all the gunk inside the throttle body

put a new TPS and Idle control sensor on it big chance it will be fine. chuck new vaccum hoses on it clamp them up good.
 
Top