Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VY Berlina V6 Rev and idle rough

Discussion in 'VY Holden Commodore (2002 - 2004)' started by Goolz96, May 17, 2019.

Tags:
  1. Goolz96

    Goolz96 New Member

    Messages:
    17
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Aug 14, 2018
    Location:
    Morwell
    Members Ride:
    VY Berlina S2
    Back again. The car is idling rough and revving rough.
    VY Berlina series 2, V6 Auto, petrol

    When stationary in Drive, it idles at about 1500-2000rpm and essentially takes off on its own, even on small slopes.
    When in Park, it idles at 2000-2500rpm.
    Revs don’t drop much when slowing down.
    Gears shift roughly.
    The ‘check engine’ light has come on 3-4 times within about half an hour.

    Been told the possible following:
    Throttle position sensor (TPS)
    Idle air control (IAC) valve
    Dirty MAF sensor

    Could it be anything else? Or has anyone experienced this before?

    The car had an engine swap done about a month and a half ago. Has a VT engine with roughly 185xxx on it. Oil and coolant are fine. Not missing at all. Gearbox has around 307,600. Only been doing it the past week.
     
  2. evBenji

    evBenji Active Member

    Messages:
    988
    Likes Received:
    52
    Trophy Points:
    28
    Joined:
    Dec 22, 2010
    Location:
    Adelaide
    Members Ride:
    VY Commodore
    1st step would be to clean out all the gunk inside the throttle body

    put a new TPS and Idle control sensor on it big chance it will be fine. chuck new vaccum hoses on it clamp them up good.
     

Share This Page