Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VY Berlina v6 - stalling, climate control and no main display issues

Campo500

New Member
Joined
May 1, 2020
Messages
2
Reaction score
0
Points
1
Age
20
Location
South Australia
Members Ride
VY Berlina
Hey guys just picked up a v6 Berlina the other day and I’m just hoping I could have a little help, my knowledge is quite mild and I want to get the best advice possible before going out spending big money

So this is the third day I had it, she’s been running nicely, engines definitely healthy but it stalled twice on the way to work randomly, didn’t have any problems on the way home, I gave it a little booting this morning to see if I could find something and I think it possibly could be related to the coils, sparks and leads, just like my old VS which the coils were definitely screwed in that car which I replaced all 3, sparks and leads in then it ran fine, my VY with a decent amount of acceleration had some slight I guess “sluggish” to it, like it’s not going to its full potential but then I’m reading also about O2 sensors? Honestly not completely sure

the other two issues I have is my main display on the cluster there is nothing, it’s illuminated but doesn’t say anything, the other issue is related to aircon/heater, my dimisters works fine but not sure what’s going on with my aircon/heater (climate control unit in general)

the last two issues I’m just scratching my head, if someone could please give me some help it would be greatly appreciated

The climate control I genuinely have no idea what’s going on

cluster display?
https://imgur.com/I1nMv0B
 

Campo500

New Member
Joined
May 1, 2020
Messages
2
Reaction score
0
Points
1
Age
20
Location
South Australia
Members Ride
VY Berlina
I’ve uploaded the video of the climate control unit into my media, thought I attached it here but looks like it disappeared unless my phone is playing up
 

Trevor loves holden.

Well-Known Member
Joined
Jun 6, 2019
Messages
3,505
Reaction score
743
Points
113
Location
Victoria
Members Ride
vs commodore
Check the battery terminals make sure they are tight, if it just stalls while driving its either power from the battery or a bad fuel pump or pump relay, don't count out the CAS they do fail and stop your car dead.
 

Trevor loves holden.

Well-Known Member
Joined
Jun 6, 2019
Messages
3,505
Reaction score
743
Points
113
Location
Victoria
Members Ride
vs commodore
Unplug the ABS plug and see if that fixes the cluster I've read a lot of issues around that.
 

TheIceman

Active Member
Joined
Mar 18, 2006
Messages
600
Reaction score
73
Points
28
Members Ride
VY Ex-cop
Hey guys just picked up a v6 Berlina the other day and I’m just hoping I could have a little help, my knowledge is quite mild and I want to get the best advice possible before going out spending big money
well you just spent big cash getting it.
take it back to where you got it, tell him you want it fixed or get a refund or bash him.
 
Top