Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VY check engine light flashing

ChrisColumbus

New Member
Joined
Sep 9, 2015
Messages
1
Reaction score
0
Points
0
Location
sunshine coast
Members Ride
VY Acclaim S2
Hey everyone,
A few days ago my check engine light started flashing after reving over 1500rpm, i thought it was the air intake pipe but after changing that it still happens...
Also, when on the highway yesterday the temperature guage was normal then went to cold and back to normal every time the check engine light would come on (note: temperature never exceeded half way)
Could this be a possible o2 sensor issue?
cheers!
 

Boothy

Member
Joined
Mar 26, 2011
Messages
73
Reaction score
0
Points
6
Location
Melbourne
Members Ride
Vn Wagon, VY Commodore
I find that when temperature gauge changes erractically its either low on coolant or a thermostat issue. Other causes could be the gauge itself or the coolant temp sensor. Last time i had an o2 sensor problem all it did was throw the check engine light and ran like a bitch. From memory it didnt really alter engine temp
 

Bowen

New Member
Joined
Nov 19, 2011
Messages
1,128
Reaction score
10
Points
0
Age
28
Location
Alstonville
Members Ride
2002 VX S manual 3.8L SP
Find out what code it is then it will make sense, temperature could be non related and coincidental
 

JasonJohnston

New Member
Joined
Apr 16, 2016
Messages
2
Reaction score
0
Points
0
Location
New Zealand
Members Ride
Vy commodore v6 wagon
My issue is car goes great but when I put my foot down to pass a car the engine check light comes on and the car starts to shudder you stop turn car off then back on cars good as again driving me crazy can anyone help
 

redvxr8clubby

Active Member
Joined
Jan 5, 2015
Messages
871
Reaction score
162
Points
43
Location
Sunshine Coast QLD
Members Ride
VX Clubsport R8 & VE SS
When you have check engine light you need to know the codes that are the reason for the light. As you have a problem when accelerating, maybe fuel pressure related - maybe fuel filter needs replacing or fuel pump, but I would think most likely the car would just have a lack of power with extra fuel demand if that's the case. As you said the water temp gauge goes cold then back to normal, and this is when the check engine light comes on, maybe you have a problem with that water temp sensor, or the wiring to the sensor. Perhaps take a look at the wiring to the sensor either corrosion or tension in the pins on the sensor to ensure good connection. If the temp sensor or it's wiring is bad perhaps the car goes into limp mode, and displaying the check engine light. With apparent sudden drop in temp reading I'd be suspecting dodgy wiring connections.
 
Top