Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VY ECotec stock in VT body

Discussion in 'Mace Engineering' started by captain slow, Jun 2, 2016.

  1. captain slow

    captain slow New Member

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Oct 25, 2014
    Location:
    Toowoomba
    Members Ride:
    19999 VT 3.8ltr
    Hi Mace Engineering


    I have a VT V6 Ecotec with Mace Performance chip in stock engine but couple weeks ago the engine died.

    So, I have put in VY Ecotec engine which only done 126K and put in 10W 60 Penrite Racing oil with Ryco filter and also added ceratec from Liquoy Moly, but I can hear timing chain rattle. So I have asked few Mechanic they said 10W 60 is too thick. Yesterday put in HPR5 5W-40 now rattle dropped 50%. But noise is still there.


    Now I am thinking do I need to replace VT performance chip with a VY Ecotec performance chip or need to replace the VT computer with VY computer ? OR Do I send the Chip to Mace to re-program it, Please help.

    Thanks in advance.
     
  2. EYY

    EYY Well-Known Member

    Messages:
    4,916
    Likes Received:
    998
    Trophy Points:
    113
    Joined:
    Mar 6, 2011
    Location:
    Vic
    Members Ride:
    VS Statesman
    Sounds like you got a dud engine. Not much you can do other than replace the engine or pull it apart and see what's damaged. Sorry to hear.
     
  3. captain slow

    captain slow New Member

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Oct 25, 2014
    Location:
    Toowoomba
    Members Ride:
    19999 VT 3.8ltr
    Hi EYY

    Thanks for the reply. Car drives smoother, powerful and quieter than old engine apart from the tick tick at idle and sometime rattle at initial start. I might have to run it till it dies or sell it. Can't see any point of putting another engine. Spent a lot to keep it going. It's a VT but VX ss full body kit and VY engine and VY wheels. So I can call it VTXY Commodore. My first Holden & really like this car but......
     
  4. Tonner Matt

    Tonner Matt Well-Known Member

    Messages:
    1,651
    Likes Received:
    1,353
    Trophy Points:
    113
    Joined:
    May 12, 2014
    Location:
    Darwin
    Members Ride:
    VZ 1 Tonner LS1 M6
    It's possible that it is the lifters causing the rattling. But no guarantee, you may have got a dud motor as EYY said.
    Throw a bottle of Nulon Lifter Free in the motor, the cost of a bottle won't break the bank and it may just help quieten it down.
    It can take up to 500km's to be effective though according to the instructions on the bottle.

    I am usually very sceptical about "additives" and there special powers of mechanical repair, but I put a bottle of this stuff in my missus VY V6 ute and after about 200km's travelled the dreaded tick is definitely quieter at start up.
    Utes at 143,000km's now and I'm using Penrite 10w40 Semi Synthetic in it
     
  5. captain slow

    captain slow New Member

    Messages:
    7
    Likes Received:
    0
    Trophy Points:
    0
    Joined:
    Oct 25, 2014
    Location:
    Toowoomba
    Members Ride:
    19999 VT 3.8ltr
    Thank you Tonner Matt for your reply. Since my last post I took it to tranny specialist and he said the same as you one of the lifter is a bit noisy. I am definitely going to put some lifter free in the oil tomorrow. Let's see if it quiets the lifter. Thank you very much.

    I have another problem which is driving me crazy so much that I felt like burn this piece of sh!7.
    Would you have any idea why the air con compresser often don't kick in the cold weather, hence the window gets foggy. But sometime when turn off the engine and re start again then the air con starts working. I took it to an A/C mechanics couldn't fix it.

    This is a second hand air con compressor from eBay. Do you think may be needs a brand new air compressor? I'm sick of chasing answers for problems in this piece of Sh!7. No doubt I'm not having good luck with this commodore.
     
  6. VS_Pete

    VS_Pete Donating Member

    Messages:
    4,341
    Likes Received:
    7,492
    Trophy Points:
    113
    Joined:
    Dec 23, 2007
    Location:
    Brisbane
    Members Ride:
    VE II SV6 MY12 SPORTWAGON
    It`s not the wire going to the compressor.
    Start car with air con on play with wire.
     

Share This Page