Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

vy ss BF coolant leak

rydogz

New Member
Joined
May 29, 2009
Messages
128
Reaction score
0
Points
0
Location
Central Coast
Members Ride
VY II SS
Last week my car started leaking coolant luckily very close to home, I could see it dripping fast from the front of the block near the water pump.

I took the radiator out today thinking it will simply be a gasket or the pump itself but once I got my head in there the thermostat gasket was clean no signs of crusty coolant crap on the gasket.

It had FA coolant left in it (~1L) and has leaked from being 3 inches down on the reservoir to bext to nothing of 7 days of sitting in the driveway so why I cant see it is confusing me.

Could it be leaking from a welch plug also?

I did notice coolant in a cavity on the front of the block I will try and load a picture off my phone shortly. If you put your hand thru the drive belt and piut your hand behind the pump it is wet to touch but how could nearly all the coolant drain from there its too high?

Any advice other than "use search you wanker" would be greatly appreciated.
 

Dr HaxZaw

New Member
Joined
May 6, 2010
Messages
1,462
Reaction score
11
Points
0
Location
Sydney
Members Ride
R34 GT-T
could be a cracked hose. i had one and it looked like it was leaking from the pump but it was cracked underneath the hose clamp. its only 2 mins to pull it off and check so thats where id start
 

rydogz

New Member
Joined
May 29, 2009
Messages
128
Reaction score
0
Points
0
Location
Central Coast
Members Ride
VY II SS
Unfortuately its not a hose and the as I said I have taken the radiator out and had a good look at that...

Putting the radiator back in now and going to run her with demineralized water and watch like a hawk.

I'll let you know in an hour...
 

rydogz

New Member
Joined
May 29, 2009
Messages
128
Reaction score
0
Points
0
Location
Central Coast
Members Ride
VY II SS
Leaking from the front of the block above the middle of three small pulleys on the left looking into the bonnet from that cavity behind the water pump.

Is it the gasket or the tell tale hole on the water pump?

Anyone got a photo of the hole?

Cheers.
 

Dr HaxZaw

New Member
Joined
May 6, 2010
Messages
1,462
Reaction score
11
Points
0
Location
Sydney
Members Ride
R34 GT-T
it could also be the seals on your water pump... got them done about six months ago and if its coming from the left side of the block id be def having a look at the water pump
 

rydogz

New Member
Joined
May 29, 2009
Messages
128
Reaction score
0
Points
0
Location
Central Coast
Members Ride
VY II SS
I finally found the cable for my phone, this is a picture of the leak.
 

colgf

New Member
Joined
Sep 6, 2007
Messages
351
Reaction score
3
Points
0
Members Ride
s/charged v6 HR Holden, s/charged v6 EH Holden,
I finally found the cable for my phone, this is a picture of the leak.
It is definitely the water pump , had exactly the same leak on my 2005 CV8Z monaro. It leaked only after turning off motor after a run , the pressure builds up & water was forced past the thin wall of the water pump between gasket & it and engine block , buy a good quality water pump , up for $300 at least for a good one , Make sure you buy quality coolant too. Bugger of a job to remove radiator & fans & belts but after that all easy , buy new belts & hoses at same time......
 

rydogz

New Member
Joined
May 29, 2009
Messages
128
Reaction score
0
Points
0
Location
Central Coast
Members Ride
VY II SS
Cheers for the reply. If its leaking from the gasket between the pump and the block but NOT the weep hole is the pump actually rooted or can I just get the gasket?

Already have the radiator out thats the easy part, drive belt will be a pain in the arse.

Does the water pump come with a new thermostat and/or thermostat housing/gasket or is it separate?
 
Top