Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VZ hazard relay type

Discussion in 'Electrical Wiring / Questions' started by Sikkinixx, Oct 29, 2018.

  1. Sikkinixx

    Sikkinixx Ford Traitor :(

    Messages:
    19
    Likes Received:
    2
    Trophy Points:
    3
    Joined:
    Sep 22, 2013
    Location:
    Brisbane
    Members Ride:
    04 VZ Wagon
    Hi all,
    Just repaired some damage on a VZ wagon I bought ridiculously cheap, ready for roady. Was checking everything and realized I had indicators, but no hazard or remote lock lights. Swapped fuse with brake light one (which were working), still nothing.
    When I turn hazards on, can hear the tick tick tick LIKE they're working but no blink blink blink. Lol
    Where the hazard relay is meant to be, there's an empty slot (map says Hazard Illum warning (GMB) is GMB significant?). I tried to use other relays, even out of my VT, but they either didn't fit, or just flopped around if they did. And theres nothing in the spare slot below it, so nothing to compare to (ones with white stripe to the right didn't fit).
    Any ideas? Please. IMG_20181029_201153.JPG IMG_20181029_201327.JPG IMG_20181029_201153.JPG IMG_20181029_201327.JPG
     
  2. Nut Kracker

    Nut Kracker Donating Member

    Messages:
    4,760
    Likes Received:
    129
    Trophy Points:
    63
    Joined:
    Oct 18, 2012
    Location:
    Echuca Vic.
    Members Ride:
    VT SS 304ci (195i)
    Been having a bit of a search on this problem and it seems quite common with the VZ models.
    You'll probably find that the relay hasn't got any contacts and is not wired.
    From what I have researched on this topic, is that the hazard relay is in the BCM and is probably faulty
    and will either be in need of repair or the BCM replaced.
     
    Brady Leighton likes this.
  3. VT2Commie

    VT2Commie Active Member

    Messages:
    201
    Likes Received:
    61
    Trophy Points:
    28
    Joined:
    Jan 1, 2018
    Location:
    WA
    Members Ride:
    VT2 Clubsport R8
    Press the hazard switch in and out like crazy about twenty times, on/off/on/off/on/off, the contacts are known to tarnish from lack of use.

    See how that goes. If no joy, what Nut Kracker has said. BCM internal relay fooked. New BCM.
     
    Last edited: Nov 8, 2018

Share This Page