Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VZ LS1 Accelerator Pedal Position Sensor

Fu Manchu

Well-Known Member
Joined
Mar 18, 2006
Messages
4,626
Reaction score
2,218
Points
113
Location
WA.
Members Ride
Slug powered VZ, Cross 8 VZ, VE Calais & ya mum.
ABBC8D63-BAE3-4FB7-9555-584F5180C147.jpeg

The back of the BCM in bottom right corner.

34D88C7B-C324-4912-8C22-C8009EC66244.jpeg

Back of BCM right of image. Firewall is on the left. (That grot :oops:)

EC3663B9-D14A-46A8-A5D6-90BE2CA417F7.jpeg


Great. That grot is going to bother me now.
 
Last edited:

Jolls

Active Member
Joined
Mar 2, 2017
Messages
116
Reaction score
81
Points
28
Location
Murrumbateman
Members Ride
VZ SS Ute
Hi Fu,

Thanks mate (passes beer back). If I have it right this is the V6 setup - not at all what mine looks like. (edit - this is incorrect information - the pictures are of the LS1 pedal and do reflect my situation - however, the diagrams above are incorrect. The B22 connector is incorrectly numbered in the manula anbd the screen shot of the wiring diagram is fram a V6 - hence the following bit of confusion) )It does match exactly the Haltech pinout at the Gen III pedal though for the pedal number my beast is supposed to have. The pins seem to match the pedal that I have as well - so the wiring I have been running with may be all over the shop. I have been running off the wiring guide from the manual below:

Colour Code Drive By Wirejpg_Page1.jpg

The pins at the pedal don't give the responses expected and my 5V outputs from the TACM don't match the Haltech pins at all. So.... I bit the bullet over the weekend and purchased a new harness complete from the TACM to the pedal from LSXtreme.

This, touch wood, should give me the right setup for the pedal from the TACM instead of me guessing the wiring. I trust when it arrives that I just plug it in and she runs. I will post photos of the provided harness compared to the wiring diagram.

More to follow in due course
 
Last edited:

Fu Manchu

Well-Known Member
Joined
Mar 18, 2006
Messages
4,626
Reaction score
2,218
Points
113
Location
WA.
Members Ride
Slug powered VZ, Cross 8 VZ, VE Calais & ya mum.
That is V8. LS1
 

Jolls

Active Member
Joined
Mar 2, 2017
Messages
116
Reaction score
81
Points
28
Location
Murrumbateman
Members Ride
VZ SS Ute
That is V8. LS1
mmmm - confusion now. So yours does not have a TACM - the pedal is linked to the BCM? My wiring is completely different. The pedal runs to the TACM in the passenger kickpanel - see below. Have I got it completely wrong? Continuity tests lead me to think not.

Screen Shot 2020-11-15 at 5.02.49 pm.png
 

Fu Manchu

Well-Known Member
Joined
Mar 18, 2006
Messages
4,626
Reaction score
2,218
Points
113
Location
WA.
Members Ride
Slug powered VZ, Cross 8 VZ, VE Calais & ya mum.
The TAC module is what you have there in the picture, that 7 (in your diagram) plugs into A111 in the wiring diagram. A84 is the ECM. B22 is the pedal. The actuator assembly is on the throttle (TPS2 & TPS1).
 
Last edited:

Fu Manchu

Well-Known Member
Joined
Mar 18, 2006
Messages
4,626
Reaction score
2,218
Points
113
Location
WA.
Members Ride
Slug powered VZ, Cross 8 VZ, VE Calais & ya mum.
The photo of the pedal wiring matches the wiring diagram. 8 pin plug. 6 wires.
These run directly to the TAC Module.
A873972B-269A-4786-9751-3DA54D3B103A.jpeg

Screen Shot 2020-11-22 at 7.53.07 pm.png
 

Fu Manchu

Well-Known Member
Joined
Mar 18, 2006
Messages
4,626
Reaction score
2,218
Points
113
Location
WA.
Members Ride
Slug powered VZ, Cross 8 VZ, VE Calais & ya mum.
The two plugs going into it are labeled X1 and X2.
The wiring from the pedal to the TAC Module is plug X2 (The bottom plug). To the actuator on the throttle body, ECM and other components is X1 (The top plug).
 

Fu Manchu

Well-Known Member
Joined
Mar 18, 2006
Messages
4,626
Reaction score
2,218
Points
113
Location
WA.
Members Ride
Slug powered VZ, Cross 8 VZ, VE Calais & ya mum.
The two 5v reference wires are white/blk and tan.
 

John Soko

New Member
Joined
Nov 16, 2017
Messages
3
Reaction score
0
Points
1
Age
59
Location
Hunter Valley
Members Ride
VZ Adventra
I read with great interest! My VZ LS1 Adventra is playing silly buugers atm. Runs fine, then randomly drops into 'Safe Mode'. Real handy at 100km/h with a truck on the bumper - Not! Can do this once in 300k's, or, 4 times in 20k's. Fault code does not pinpoint what is at fault - pedal or throttle body.
Good luck with your projrct!
Cheers
John
 
Top