Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Vz sv6 P0030 code

Discussion in 'VZ Holden Commodore (2004 - 2006)' started by Mattbeggs91, May 11, 2018.

  1. Mattbeggs91

    Mattbeggs91 New Member

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Apr 26, 2018
    Location:
    Oran Park NSW
    Members Ride:
    VZ SV6
    i have a vz sv6 I’ve replaced the o2 sensor bank 1 sensor 1 but still getting the code ? Can anyone shine some light onto this
     
  2. 99notout

    99notout Active Member

    Messages:
    366
    Likes Received:
    28
    Trophy Points:
    28
    Joined:
    Aug 10, 2013
    Location:
    Adelaide
    Members Ride:
    VZ Equip Wagon
    People have make this mistake in the past, not saying you did, but, just making sure that you did the front one (pre cat) on the drivers side?
     
  3. Mattbeggs91

    Mattbeggs91 New Member

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Apr 26, 2018
    Location:
    Oran Park NSW
    Members Ride:
    VZ SV6
    So I replaced drivers side front just before the cat. The odd thing is using an obd for live data it is sitting at 0.004v no matter how I’m driving
     
  4. gungazza

    gungazza Active Member

    Messages:
    1,016
    Likes Received:
    9
    Trophy Points:
    38
    Joined:
    Feb 8, 2005
    Location:
    west suburbs
    Members Ride:
    executive vt 5.0lt VZ CREWMAN
    did you change both left and right
     
  5. Mattbeggs91

    Mattbeggs91 New Member

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Apr 26, 2018
    Location:
    Oran Park NSW
    Members Ride:
    VZ SV6
    No only the right as the code is for bank 1 sensor 1 ?
     
  6. gungazza

    gungazza Active Member

    Messages:
    1,016
    Likes Received:
    9
    Trophy Points:
    38
    Joined:
    Feb 8, 2005
    Location:
    west suburbs
    Members Ride:
    executive vt 5.0lt VZ CREWMAN
  7. gungazza

    gungazza Active Member

    Messages:
    1,016
    Likes Received:
    9
    Trophy Points:
    38
    Joined:
    Feb 8, 2005
    Location:
    west suburbs
    Members Ride:
    executive vt 5.0lt VZ CREWMAN
    if the right one stuffed, left will be also
     
  8. Sean880

    Sean880 Well-Known Member

    Messages:
    1,192
    Likes Received:
    176
    Trophy Points:
    63
    Joined:
    May 14, 2009
    Location:
    VIC / NSW
    Members Ride:
    2012 VE SV6 ser 2 and 911 Porsche Carrera S 997
    Looks like the sensor might not be working and if it is new then suspect the wiring to the sensor.

    But you need to check the voltage with a proper tool first. The best way to observe O2 sensor output voltage changes is with a Digital Storage Oscilloscope (DSO). A scope will display the sensor voltage output as a wavy line that shows both it's amplitude (minimum and maximum voltage) as well as its frequency (transition rate from rich to lean).
     
  9. Sean880

    Sean880 Well-Known Member

    Messages:
    1,192
    Likes Received:
    176
    Trophy Points:
    63
    Joined:
    May 14, 2009
    Location:
    VIC / NSW
    Members Ride:
    2012 VE SV6 ser 2 and 911 Porsche Carrera S 997
    Not necessarily and it could have been changed previously.
    In any event changing the bank 2 sensor is not going to solve the issue with the Bank 1 sensor trouble code.
    If the B2 sensor was bad there would also be a trouble code generated for it and there is not.
     
  10. 99notout

    99notout Active Member

    Messages:
    366
    Likes Received:
    28
    Trophy Points:
    28
    Joined:
    Aug 10, 2013
    Location:
    Adelaide
    Members Ride:
    VZ Equip Wagon
    Might have got a bad one, but not that likely, are you sure you got the plug/connector on top of the trans connected solidly?
     
  11. gungazza

    gungazza Active Member

    Messages:
    1,016
    Likes Received:
    9
    Trophy Points:
    38
    Joined:
    Feb 8, 2005
    Location:
    west suburbs
    Members Ride:
    executive vt 5.0lt VZ CREWMAN
    worth a try take out the sensor and put the other old one in see what happens
     
  12. Mattbeggs91

    Mattbeggs91 New Member

    Messages:
    8
    Likes Received:
    0
    Trophy Points:
    1
    Joined:
    Apr 26, 2018
    Location:
    Oran Park NSW
    Members Ride:
    VZ SV6
    Will try swapping left to right old with new on the weekend and report back. Thanks so far :)
     

Share This Page