Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VZ Ute airbag error

Pezvz

New Member
Joined
Jun 5, 2019
Messages
2
Reaction score
0
Points
1
Age
56
Location
Ulladulla
Members Ride
VZ ute
I have just bought my first ute ever, an '06 VZ. But I get an SRS airbag alarm every time I start it. The guy who sold it to me told me that he had replaced the instrument cluster from a VZ sedan and the alert was because it couldn't detect any rear airbags. I have read that even Holden shops can't clear the error because it's a safety thing. First question - is the missing back seats likely to be the problem? Second question - how do I fix the alarm? Third bonus question - how can I be sure the existing airbags are functional without doing a full test (ie crashing the car)?
Thanks
 

Fu Manchu

Well-Known Member
Joined
Mar 18, 2006
Messages
7,951
Reaction score
5,297
Points
113
Location
WA.
Members Ride
Slug powered VZ, Cross 8 VZ, VE Calais & ya mum.
The cluster is easily reflashed to be set up to the ute. Envyous Customs do it. They are forum sponsors and have a section in the forum front page.you can also go to their webpage for more info.
 

Fu Manchu

Well-Known Member
Joined
Mar 18, 2006
Messages
7,951
Reaction score
5,297
Points
113
Location
WA.
Members Ride
Slug powered VZ, Cross 8 VZ, VE Calais & ya mum.
In relation to the airbags, check the fuses for continuity with a multimeter. Disconnect the battery first.
 

Pezvz

New Member
Joined
Jun 5, 2019
Messages
2
Reaction score
0
Points
1
Age
56
Location
Ulladulla
Members Ride
VZ ute
The cluster is easily reflashed to be set up to the ute. Envyous Customs do it. They are forum sponsors and have a section in the forum front page.you can also go to their webpage for more info.
Thanks Fu Manchu, I will check them out.
 

Fu Manchu

Well-Known Member
Joined
Mar 18, 2006
Messages
7,951
Reaction score
5,297
Points
113
Location
WA.
Members Ride
Slug powered VZ, Cross 8 VZ, VE Calais & ya mum.
I have just bought my first ute ever, an '06 VZ. But I get an SRS airbag alarm every time I start it. The guy who sold it to me told me that he had replaced the instrument cluster from a VZ sedan and the alert was because it couldn't detect any rear airbags. I have read that even Holden shops can't clear the error because it's a safety thing. First question - is the missing back seats likely to be the problem? Second question - how do I fix the alarm? Third bonus question - how can I be sure the existing airbags are functional without doing a full test (ie crashing the car)?
Thanks
As for the airbags being tested, this can be done by using a GM Tech 2 connected to the cars OBD port under the steering wheel.
That is done by a garage or Holden.
Lets do the basic stuff first.

1. Check fuses
2. Get the cluster correctly set up to the vehicle.
3. Use a Tech2 module to further investigate any recurring faults (not just reread codes)
 
Top