Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

VZ V6 adventra 195kw camshaft position sensor

Bjadventuring

New Member
Joined
Jan 25, 2019
Messages
1
Reaction score
0
Points
1
Age
49
Location
Melbourne
Members Ride
06 VZ adventra v6
had my engine rebuilt because of some metal going down the air intake,( it was something the previous owner had put inside intake pipe to increase air flow)any way everything was done also did the starter motor because that was starting to play up just before the big bang happened. Since then the camshaft position sensor b circuit range bank 2 keeps coming up, I've had sensors swapped around and also checked but still not right, been told a software update at Holden, car has been running nicely but now the catylactic converter has **** itself it's been about 3-5000klms since rebuild also been told this code will come up with starter being replaced, when I clear the code and drive it the code doesn't reappear untill restart, has anyone got a clue, or comment
 

_R_J_K_

Well-Known Member
Joined
Dec 20, 2008
Messages
5,839
Reaction score
1,155
Points
113
Members Ride
Zenki S14
Can you chase back the loom from the sensor and see if it's damaged anywhere or if any pins have come out of the plugs?

Only other thing I could think of is that one of the cam phasers could be damaged or there's something on it.
 
Top