Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Water pump

holden123

New Member
Joined
Feb 8, 2009
Messages
88
Reaction score
1
Points
0
Location
adelaide
Members Ride
commodore VX SS SII
Hi, need help got up and left for work, reverse the car back and seen a coolant on the ground check for a leak could not see one.when i got to work check again, still could not see a leak. no coolant on the ground when i left work but check again when i got home and seen green stain under the water pump. but no leak could it be just leaking from the water pump over night ?:bang: any help would be great thanks
 
Last edited:

VN Lukey

BT1, the way to go
Joined
May 27, 2009
Messages
136
Reaction score
0
Points
0
Members Ride
Holden VN S1
Hey mate...first the reason it might not be leaking anymore is because you prob dont have any collant left in there...LOL...

fil it up and let it run for a bit and keep an eye on it and you will find your problem...

check to see that the pump is in tight and the screws havnt become loose..

but you probs need a new water pump...if its ok idd rip it off and put a new gasket on and put it back on...

you should be fine then..

let us know how you go mate.. good luck
 

levymetal

TURN MY HEADPHONES UP
Joined
Dec 29, 2007
Messages
1,259
Reaction score
27
Points
48
Location
Somerville, Victoria
Website
levymetal.net
Members Ride
HSV ENHANCED VP CALAIS
probably leaks after the car has been stopped because that's when the pressure starts building up. water pump is a relatively cheap and easy fix :). don't forget to get new hoses while you're at it though.
 

holden123

New Member
Joined
Feb 8, 2009
Messages
88
Reaction score
1
Points
0
Location
adelaide
Members Ride
commodore VX SS SII
Hey mate...first the reason it might not be leaking anymore is because you prob dont have any collant left in there...LOL...

fil it up and let it run for a bit and keep an eye on it and you will find your problem...

check to see that the pump is in tight and the screws havnt become loose..

but you probs need a new water pump...if its ok idd rip it off and put a new gasket on and put it back on...

you should be fine then..

let us know how you go mate.. good luck
thanks coolant level is fine check it every week, rang the place that built the motor for me today and got the cold shoulder you think after spending $3000 on the motor they would take a look, as all the gasket were done and new water pump.
i think it's the gasket by how it's leaking find out tomorrow
 

VN Lukey

BT1, the way to go
Joined
May 27, 2009
Messages
136
Reaction score
0
Points
0
Members Ride
Holden VN S1
Hey mate..

howd u go with it all.. was it the water pump gasket..?

yer that is pretty tight.. giving you the cold shoulder.. i would have cracked it and told them if that happend to me..LOL
 
Top