Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Wickham_1995

New Member
Joined
Jun 9, 2014
Messages
26
Reaction score
3
Points
3
Age
29
Location
Victoria
Members Ride
ZB Holden Calais V 3.6L AWD Hatchback
Hey guys,

Recently bought a 2018 Calais V with AWD LGX V6. Coming home from Melbourne last night, temperature gauge was working and noticed about an hour later that hit had dropped to '50' and never moved. Have the typical thermo fan run for about 5 minutes after shutdown and no A/C. Scanned it this morning and have code P0128 (Coolant temperature below thermostat regulating range) confirmed with live data that my temperature sensor is reading correct and that when i put my heater on it does blow hot air. Being a second hand vehicle and most likely out of warranty I'm going to have to pay for this myself. Have any of you had this job done out of warranty? and how much did it set you back? Also if you have a part number for the thermostat would be great as it's very difficult to find online under the rego/holden variant. Can find a few things for the Opel and the Camaro that run the same engine but obviously to find the right part for our application. Any help will be greatly appreciated.
 

higherVXR

New Member
Joined
Aug 29, 2022
Messages
12
Reaction score
9
Points
3
Location
Sydney
Members Ride
2018 Commodore ZB VXR 3.6L V6
Hey mate, I just had the same thing happen two weeks ago. Mine is a second hand 2018 VXR. Got it into my local Holden Service Centre this week after telling them the issue.

They said that this was a semi-common problem with the ZB's and knew exactly how to fix. Dropped it off and they ended up fixing under warranty (my car is definitely over 5 years old and out of warranty). I guess because it's a common issue in the ZB's some of the Holden service places are still fixing under warranty?

This is the info under the entry on their receipt they gave me:

CHECKED AND CONFIRMED FAULT FOUND FAULT CODE RELATING TO THERMOSTAT BELOW REGULATING TEMP , CARRIED OUT ALL
NECESSARY DIAGNOSIS FOUND THERMOSTAT ASSEMBLY TO HAVE
FAILED INTERNALLY AND WOULD REQUIRE REPLACING
REMOVED AND REPLACED THERMOSTAT ASSEMBLY AS REQUIRED TESTED ALL OK
GM12678779 OUTLET ASM-WAT

Not sure if that bottom number might be a model or part number you could be looking for.

I'd definitely try and get it checked out by a service centre first if possible. Hopefully they're as helpful as my local. Good luck with it!
 

higherVXR

New Member
Joined
Aug 29, 2022
Messages
12
Reaction score
9
Points
3
Location
Sydney
Members Ride
2018 Commodore ZB VXR 3.6L V6
Also on another note - there is a temporary fix that another member here suggested. If you disconnect the negative battery terminal for about 30-60 secs and re-connect it should clear the fault code temporarily and the thermostat & AC will work again for a week or so. It will inevitably fail again but at least the engine temp is readable and you don't get the fan / no AC issue.
 

Wickham_1995

New Member
Joined
Jun 9, 2014
Messages
26
Reaction score
3
Points
3
Age
29
Location
Victoria
Members Ride
ZB Holden Calais V 3.6L AWD Hatchback
Hey mate, I just had the same thing happen two weeks ago. Mine is a second hand 2018 VXR. Got it into my local Holden Service Centre this week after telling them the issue.

They said that this was a semi-common problem with the ZB's and knew exactly how to fix. Dropped it off and they ended up fixing under warranty (my car is definitely over 5 years old and out of warranty). I guess because it's a common issue in the ZB's some of the Holden service places are still fixing under warranty?

This is the info under the entry on their receipt they gave me:

CHECKED AND CONFIRMED FAULT FOUND FAULT CODE RELATING TO THERMOSTAT BELOW REGULATING TEMP , CARRIED OUT ALL
NECESSARY DIAGNOSIS FOUND THERMOSTAT ASSEMBLY TO HAVE
FAILED INTERNALLY AND WOULD REQUIRE REPLACING
REMOVED AND REPLACED THERMOSTAT ASSEMBLY AS REQUIRED TESTED ALL OK
GM12678779 OUTLET ASM-WAT

Not sure if that bottom number might be a model or part number you could be looking for.

I'd definitely try and get it checked out by a service centre first if possible. Hopefully they're as helpful as my local. Good luck with it!
Cheers man, it's good to know some dealers are still doing this fix under good will. Hopefully my local dealer with be forgiving aswel
 

Wickham_1995

New Member
Joined
Jun 9, 2014
Messages
26
Reaction score
3
Points
3
Age
29
Location
Victoria
Members Ride
ZB Holden Calais V 3.6L AWD Hatchback
Just a little update:



Went for a drive today and the temp gauge started working. I know it'll be temporarily until it happens again but annoying because I was going to take it to the dealer tommoro to be diagnosed.



Will keep posted.
 
Top