Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

WH Statesman Heater and Air Conditioning Fans Not Working

Brysha89

Active Member
Joined
Dec 9, 2018
Messages
329
Reaction score
41
Points
28
Age
31
Location
Melton,Victoria
Members Ride
WM Statesman L98 6.0ltr
Hello again JC Member's & Guest's as My Thread Head says my Fans for heating and cooling the inside of my car are not working i have changed the fuse to the whole heating control and still nothing. What am i Looking At Price wise as it's going to be beyond my capability's?
 

accentstencil

Well-Known Member
Joined
Jun 30, 2005
Messages
8,268
Reaction score
464
Points
83
Age
69
Location
Eschol Park, Sydney
Members Ride
WH II Caprice, 5.7 2018 Equinox LTZ V
There is only one fan and I bought one recently from Holden and it was about $300 if my memory serves me correctly. First you should remove the fan assembly and check it to see if it is in fact stuffed. Sometimes a good clean can get them going again. Mine was still working but a little rusty in places and the bearings weren't too good either. When you pull the fan out connect it to 12 volts and see if it works, if it does you might have a wiring problem. Also check the blower relay first.
 

BlackVXGTS

Well-Known Member
Joined
Aug 14, 2004
Messages
4,413
Reaction score
1,131
Points
113
Location
Melbourne, SE
Members Ride
GEN-F2 GTS A6, VS Clubsport 185 A4
Do the fans not work on any speed setting, or do they only work on the highest speed setting. The highest speed setting works directly off the fan relay. The other speeds work off a fan amplifier which gives the variable speeds. The fan amplifier can be repaired/replaced quite cheaply, and removal/installation is also very easy.
 

Brysha89

Active Member
Joined
Dec 9, 2018
Messages
329
Reaction score
41
Points
28
Age
31
Location
Melton,Victoria
Members Ride
WM Statesman L98 6.0ltr
it dose not operate at all, light's come on settings can be set i.e. air con, heater outside temp but no fans to push the air out of the vent's.
 

Brysha89

Active Member
Joined
Dec 9, 2018
Messages
329
Reaction score
41
Points
28
Age
31
Location
Melton,Victoria
Members Ride
WM Statesman L98 6.0ltr
There is only one fan and I bought one recently from Holden and it was about $300 if my memory serves me correctly. First you should remove the fan assembly and check it to see if it is in fact stuffed. Sometimes a good clean can get them going again. Mine was still working but a little rusty in places and the bearings weren't too good either. When you pull the fan out connect it to 12 volts and see if it works, if it does you might have a wiring problem. Also check the blower relay first.
accentstencil i would not have a clue where to find that i'm no mechanic and no auto elec but refuse to go to one as i have been ripped off 5 times in my area so i do my own repairs and services now, and i have never touched wiring on a car be for besides changing a battery terminal, hence the reason for asking how much to get it done by one so i can tell what ever crap mechanic in my area how much it should cost so they don't rip me off. but if its an easy job could you point me to how i get to the fan?
 

Brysha89

Active Member
Joined
Dec 9, 2018
Messages
329
Reaction score
41
Points
28
Age
31
Location
Melton,Victoria
Members Ride
WM Statesman L98 6.0ltr
I also brought Rear Shocks for my statesman at Auto Barn Yesterday when asking for them i was asked by the person who served me if it had self leveling shocks im prity sure sires 1 Gen 3's had the standard and sires 2 WH's like you're one accentstencil had the self leveling shocks yer?
 

accentstencil

Well-Known Member
Joined
Jun 30, 2005
Messages
8,268
Reaction score
464
Points
83
Age
69
Location
Eschol Park, Sydney
Members Ride
WH II Caprice, 5.7 2018 Equinox LTZ V
Mine didn't come with Level Ride, I installed it myself.
If you have it you will hear the compressor cut in soon after starting the car (unless it isn't working) it's pretty loud so you would hear it.
There would also be a relay in the fuse panel in the engine bay, I have marked it in red in the picture.

fuse box engine bay l.jpg


The compressor would be up above the driveshaft on the passenger side.
 

accentstencil

Well-Known Member
Joined
Jun 30, 2005
Messages
8,268
Reaction score
464
Points
83
Age
69
Location
Eschol Park, Sydney
Members Ride
WH II Caprice, 5.7 2018 Equinox LTZ V
Believe it or not, removing the blower is quite easy. You remove the plastic cover below the glovebox in the foot well, I think it just clips into place.
Then I think it's just a matter of undoing 3 screws that hold the blower assembly in place, undo the electrical connector and maneuver it out.
Theoretically it should not cost a lot because it doesn't take long but you never know.
 

Brysha89

Active Member
Joined
Dec 9, 2018
Messages
329
Reaction score
41
Points
28
Age
31
Location
Melton,Victoria
Members Ride
WM Statesman L98 6.0ltr
Tyvm accentstencil for the info ill have a look today at the fuses in the engine bay see if that fuse is there and and see if i can pull the blower out to test if its that hopefully it is and not a wiring problem
 
Joined
Mar 12, 2018
Messages
131
Reaction score
6
Points
18
Age
51
Location
Melbourne
Members Ride
2000 l67 commodore berlina
do u mean the climate fan control fans r not working in the cabin ie when u turn the fan on if the car r u or r u not getting any air blowing through the vents? if not i can tell u how to fix this!
 
Top