Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

whats going on ?

oOSparkyOo

New Member
Joined
Oct 24, 2008
Messages
39
Reaction score
0
Points
0
Location
Adelaide
Members Ride
L67 vt series 2 calais
hi just got my exhaust done 2 days ago drove it around on Saturday night and this massive bang went off like 2 tires blowing out.
I then looked under the hood and my air intake was laying in the bay and snapped off the mounts the hose clamp was loose
I then put it all back and tighten it up and the car ran fine then a few hour later the car started stalling and oil light comes on so i changed my oil and notice theirs only 2ltrs left in the sump so i change the trans and found only 2.1ltr or fluid left but the car had been services like 1 month ago what is wrong with it the car runs fine on gas but then in petrol it stalls at 50-60 im thinking fuel pump or somethings really screwed up

any help would be nice


oOsparkyOo
 

HARVZ-6

New Member
Joined
Nov 2, 2008
Messages
826
Reaction score
2
Points
0
Age
29
Location
Riverton sa
Members Ride
VT spac super6
was it running on lpg when it backfired?

how low where the revs getting an was the oil light staying on?

when revs get real low theres jack all oil pressure and on comes the light
 

oOSparkyOo

New Member
Joined
Oct 24, 2008
Messages
39
Reaction score
0
Points
0
Location
Adelaide
Members Ride
L67 vt series 2 calais
when it happened the car went bang i looked in the bay and the id assume its the chip or something but its directly behind the intake and its little black box with gm write on it cable was disconnected but i put it back in and the car started and ran fine but then later on the stalled and oil light cam on now when it stalls oil light on engine light on and it just stats up stright away but then stalls again at 50-60

no oil light prior to stall but its shudders and then loses revs and stops then engine and oil light stay on turn car off and start up again on gas and works fine
 
Top