Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

windscreen squirter

Tom04

New Member
Joined
Oct 13, 2005
Messages
95
Reaction score
0
Points
0
Location
close to Pt Augusta S.A
Members Ride
Vs S2
Hello there

My squirters dont work.
My squirteres havnt been working since i got the car. I can hear the motor going bzzz when i try and squirt, but nothing comes out the little nobs. I took the bottle out today and just connected the wire to the bottle an tried squirting and no water came out. i took the bottle out and blew through the little nipple that the rubber pipe fits onto an i blew bubbles in the bottle so there cant be a blockage.

whats stopping my squirters from squirting?

Is the motor stuffed? do i have to buy a new motor? or do i buy a new bottle an the motor comes with it? because i tried to take the motor of but i couldnt see how to get it of.
how much would a new one be?
 

94SVR

New Member
Joined
Aug 7, 2006
Messages
10
Reaction score
0
Points
0
Members Ride
VR Commodore S
u might have to clean the little filter on the motor if it has one, the motor should just pull off i think
 

kopper69

New Member
Joined
Jul 20, 2005
Messages
2,617
Reaction score
36
Points
0
Age
35
Members Ride
VRII Acclaim
I used to have this problem too. Basically you need to drop the bottle down (just one or two screws) and the motor should manoeuvre out. Its been a while since i did it last so dont quote me. The problem is that gunk and slime build up and sit on the lowest point, which is where the pump sucks from. There is a small filter, which does its job blocking the gunk entering the pump and tubing, but becomes blocked and doesnt let anything through. I did the same thing, tried blowing back, bubbles come through. But yeah, take it out, clean the gunk, flush it out with clean water, and you should be right for another few years. I guess water sitting there is going to build up slime, so no way around it. But i did it when i first got the car and about 4 years later (just recently). Fixed it both times.
 

Tom04

New Member
Joined
Oct 13, 2005
Messages
95
Reaction score
0
Points
0
Location
close to Pt Augusta S.A
Members Ride
Vs S2
but when i sucked on the knob water came through... an i tryed cleaning the bottle but there wasnt anything in there to clean
 

joesvs

New Member
Joined
Aug 10, 2005
Messages
74
Reaction score
0
Points
0
Age
38
Location
Perth
Members Ride
97 VS Wagon
your lucky when you sucked on that knob nothing else came through :rofl: ROFL
 

kopper69

New Member
Joined
Jul 20, 2005
Messages
2,617
Reaction score
36
Points
0
Age
35
Members Ride
VRII Acclaim
Drop the bottle anyway and take the pump out. You can test the pump with 12v out of the car and make sure its working. Make sure there isnt a layer of slime on the inside of the container. You really cant get to it unless the pump is pulled out. Otherwise just put water in where the pump would normally pump into it and make sure theres nothing blocking it. Thats all there is to the system.
 

Crunkz0r

Wagon driver
Joined
Sep 22, 2006
Messages
30
Reaction score
0
Points
0
Location
Brisbane
Members Ride
VR exec Wagon v6 auto
your lucky when you sucked on that knob nothing else came through :rofl: ROFL
LMFAO! i found that a bit subtle aswell... lol

Anyway, yeah i think i got the same problem u have, but my rear squirter stopped working, as in it was working before, but when it did work all this junk came out all over my back window (looked like bird s##t) then it stopped working... so ill probably have to clean the filter thing eh :thumbsup:
 

Patrio7

3Y3 K4N 5P33K 1337.
Joined
Jul 25, 2005
Messages
1,269
Reaction score
25
Points
0
Age
35
Location
Perth, Como
Members Ride
'96 S1 VS Exec
no breaks in the tubing anywhere?
maybe get a mouth full of water and let that down the hose to make sure the windscreen washer nozzles arent blocked.

which reminds me, i really ought to re-adjust mine, the right hand nozzle on my drivers side shoots up and right over the car lol
 

joesvs

New Member
Joined
Aug 10, 2005
Messages
74
Reaction score
0
Points
0
Age
38
Location
Perth
Members Ride
97 VS Wagon
^^ should point the passenger side one so it gets pedestrians LOL
 
Top