Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

02 Sensor Thread repair

rippen50

Braaap
Joined
Apr 17, 2007
Messages
179
Reaction score
1
Points
0
Location
Camden
Members Ride
VE SS-Z UTE MY12.5
Fellow jc members,

Had to take my exhaust off over the weekend and have found that the 02 sensor thread is rooted, I've done some re search and can only find videos of non helpful info!

Has anyone had this? What did u do to repair?

I have a 2.5 mild steel cat back exhaust (xforce)
 

mikey-

Member
Joined
Mar 25, 2013
Messages
225
Reaction score
4
Points
18
Location
Perth, WA
Members Ride
VE SS Sportwagon
Is it the thread on the O2 sensor, or the thread that the O2 sensor screws into?

If the first, just replace O2 sensors?

If the latter, helicoil? Run a tap through and hope for the best? Get new ones welded in?
 

rippen50

Braaap
Joined
Apr 17, 2007
Messages
179
Reaction score
1
Points
0
Location
Camden
Members Ride
VE SS-Z UTE MY12.5
Is it the thread on the O2 sensor, or the thread that the O2 sensor screws into?

If the first, just replace O2 sensors?

If the latter, helicoil? Run a tap through and hope for the best? Get new ones welded in?
Done some more research and the helicoil seems the way to go, it's the one that the sensor screws into
 

glennho

Active Member
Joined
Nov 17, 2010
Messages
461
Reaction score
89
Points
28
Age
57
Location
PERTH ,Darch WA
Members Ride
2006 VE SS
just run a tap the same thread thru the hole and all should be good.
 
Top