Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

About Engine warning light

Apoc

New Member
Joined
Apr 14, 2006
Messages
64
Reaction score
0
Points
0
Members Ride
VN-Series I-6-90
Hey peoples just when you think you have things going well, the engine warning light comes on :(. Got a few questions...

My car seems to running fairly smooth of l8 after sorting a few intake leaks, and cleaning out and sealing my pcv valve. Now when i get in the car in the morning to go to work my engine warning light comes on for about 30 sec to a min. When i pulled up at work, i turned the car off then cranked it over no warning light. I had a bit of a look around on the forum about this and people say it could be the oxygen sensor.

My car exhaust also smells quite rich... but like i said other than a bit of a rattle (timing chain / HB :unsure: ) my car is running its best yet.

But ive had my oxygen sensor replaced a couple of months ago. do they pack it in that often? If the car is given a good hard trash will that toast it?

So when that light comes on, a code is always logged in the ECU?
So i just have to do that diagnostic thingy with the paperclip and i can find out what its goin on about?

Apoc out.
 

aussieghostrider

New Member
Joined
Jun 21, 2006
Messages
251
Reaction score
3
Points
0
cars running rich ?? you just had intake manifold gaskets replaced ???

If your inlet manifold was leaking it can stuff up your o2 sensor....
Hows your fuel economy ?? getting worse ??

If so install another one,take battery lead off for few mins then put back..

if engine light still comes on it would be Alternator is buggered and or electrical regulator or loose connection...

When light comes on does car feel like its gonna stall,all lights go really dull??

if so its your Electrical regulator or Alternator... Engine light will come on....
 

lazza44

New Member
Joined
Apr 4, 2004
Messages
160
Reaction score
0
Points
0
Age
35
Location
Brisbane
Members Ride
VN S2 Berlina Wagon
My car sometimes feels like its going to stall when the light comes. I get code 13 but according to a auto electrician there is nothing wrong with the sensor. Could it be the Electrical regulator...
 
S

sami_1985

Guest
I have a similar problem with my vr commodore...when i drive on highways mine comes on but never does it in town usually when i hit about 80-90km p/h it will come on and stay on till i turn the car off. Any help would be appreciated :)
 

Apoc

New Member
Joined
Apr 14, 2006
Messages
64
Reaction score
0
Points
0
Members Ride
VN-Series I-6-90
Code 43

Turns out to be CODE 43 (DENTONATION SENSOR CIRCUIT) after i did the self-diagnostic thing last night, it really sucked as it was pissing down rain which meant i was doing all sorts of acrobatics in the passenger seat to get to the plug, with torch in mouth, rather than getting drowned and prolly pneumonia.

So i reset the comp standing apprehensively in the rain for like 10secs fuse in hand. thinking **** i hope this is the right fuse, its too shitty out to be the wrong fuse(30A ENG FUSE little box near battery and relay box).

Plugged patch cable into diagnostic link and CODE 12, unplug cable, start car no engine warning light on, drive to work and back today no probs.

Just as a bit more extreme test, to the industrial estate to get sideways on some slippery roads :driving: Check again no probs CODE 12, sweet.

Stinky exhaust havent checked that yet... Somewhere remember reading that ecu retards timing, and can expect poor fuel consumption lack of power...?
 

Apoc

New Member
Joined
Apr 14, 2006
Messages
64
Reaction score
0
Points
0
Members Ride
VN-Series I-6-90
Dude check your computer for error code

sami_1985 said:
I have a similar problem with my vr commodore...when i drive on highways mine comes on but never does it in town usually when i hit about 80-90km p/h it will come on and stay on till i turn the car off. Any help would be appreciated :)
Check your computer for error codes, as i understand it everytime that light comes on after the car has been started. an error code will be logged on you engine computer. Do a search of the forums for more info. Long story short, you can make your engine light flash the codes and from there you can know or track down what is wrong.

Hope i havent told you **** you already know, and dont know 100% that this is the same for VR's as VN's (brother has VR maybe ill find out one day) like i said check around, hope that helps ;)
 

J_D

New Member
Joined
Jul 15, 2006
Messages
352
Reaction score
7
Points
0
Location
Ipswich. QLD
Members Ride
VN S1 and VS V8 Statesman
You mention sealing up air leaks. If you use silicone sealant and its the wrong type it can **** the o2 sensor.
 
Top