Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Aerial Issues

Crowny

Active Member
Joined
Apr 13, 2011
Messages
170
Reaction score
47
Points
28
Age
45
Location
Carnegie Vic
Members Ride
VZ Executive
Hi all, I've been having issues with my aerial for a while. A lot of the time it won't go down all the way when I turn my car off. I've had the mast and rope replaced but still have the issue. Has anyone had the same issue or know any fixes? (tried a search but got an error message).
 

Fu Manchu

Septic Tank Pump Operator
Joined
Mar 18, 2006
Messages
10,206
Reaction score
8,636
Points
113
Location
WA.
Members Ride
Slug powered VZ, Cross 8 VZ, VE Calais & ya mum.
Just replace the unit. I did it with an aftermarket one (new) for $60 and it still works great after many years.
 

Trevor loves holden.

Well-Known Member
Joined
Jun 6, 2019
Messages
3,508
Reaction score
745
Points
113
Location
Victoria
Members Ride
vs commodore
Push it down by hand when off it should then go ok that's if you didn't leave broken bits inside.
 

rambunctious

Well-Known Member
Joined
Jun 9, 2011
Messages
1,999
Reaction score
879
Points
113
Location
Alexandra Headland Qld
Members Ride
VZ Executive Wagon and VZ Ute
If the mast and rope was replaced recently then it was not done correctly, or it is the wrong one.

I replaced mine about a month ago(write up on here somewhere) and it is perfect.

If it was replaced some time ago then maybe it is dirty again, so, when it is all the way up, give it a clean with a soapy steel wool pad or scourer pad you use to wash the pots and pans with, or something like that to get the crap off it, then give it a wipe with a rag and put some silicone spray onto a clean rag, or light oil etc., and wipe it on the antenna

Let's face it, the antenna is never usually up when the car is washed, so it builds up with crap until it won't go all the way down.
 

Trevor loves holden.

Well-Known Member
Joined
Jun 6, 2019
Messages
3,508
Reaction score
745
Points
113
Location
Victoria
Members Ride
vs commodore
If the mast and rope was replaced recently then it was not done correctly, or it is the wrong one.

I replaced mine about a month ago(write up on here somewhere) and it is perfect.

If it was replaced some time ago then maybe it is dirty again, so, when it is all the way up, give it a clean with a soapy steel wool pad or scourer pad you use to wash the pots and pans with, or something like that to get the crap off it, then give it a wipe with a rag and put some silicone spray onto a clean rag, or light oil etc., and wipe it on the antenna

Let's face it, the antenna is never usually up when the car is washed, so it builds up with crap until it won't go all the way down.
Just your Granma's singer sewing machine oil will do, bit on a rag and wipe !!
 

gungazza

Well-Known Member
Joined
Feb 8, 2005
Messages
1,597
Reaction score
129
Points
63
Age
65
Location
west suburbs
Members Ride
executive vt 5.0lt VZ CREWMAN
easy to replace with a new one
 
Top