Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Cammed ls1

Lotto82

New Member
Joined
Jan 31, 2019
Messages
11
Reaction score
0
Points
1
Age
39
Location
Brisbane
Members Ride
Vx ss cammed ls1
Hi guys just had ls1 built. And im running it in atm feels like its running hot. But doesnt how up on temp gauge. Also it is also leaking a bit of oil. Is it advisable to re tension things or is there a possible problem? Also put 2 and a bit litres water in it other other day. And when its hot it is throwing alot of heat at my abs system and feels like its slowing the braking up a lil. Im looking into some heat sheild for that. But sugestions about the oil leak would be much appreciated.


My new engine specs are in pic. Tia
 

Attachments

_R_J_K_

Well-Known Member
Joined
Dec 20, 2008
Messages
5,833
Reaction score
1,154
Points
113
Members Ride
Zenki S14
Have you actually identified where the oil is coming from? That would obviously be step one.

What do you mean "feels hot"? And when you say that you put in 2 litres of water, do you mean that the system lost 2 litres of water and you had top top it up? Did the cooling system get bled when the engine went back in the car? Did you by chance get extractors too?
 

Lotto82

New Member
Joined
Jan 31, 2019
Messages
11
Reaction score
0
Points
1
Age
39
Location
Brisbane
Members Ride
Vx ss cammed ls1
No cooling system wasnt bled. And abs would get hot before. But when i say feels hot i mean the engine feels hot. And has that heat smell. But putting that down to new gaskets and the fact the cam is mabee lil to big for a st car it runs fine tho and goes hard. Just put old gearbox and clutch back in. And no not seen leek area yet as only noticed today
 

Lotto82

New Member
Joined
Jan 31, 2019
Messages
11
Reaction score
0
Points
1
Age
39
Location
Brisbane
Members Ride
Vx ss cammed ls1
Also just realised what you said at en of thread. It already had paceys on it .Im only running a 2 and half in setup from previous engine but at dyno was advised a 3in setup would be alot benificial.
 

accentstencil

Well-Known Member
Joined
Jun 30, 2005
Messages
8,267
Reaction score
462
Points
83
Age
69
Location
Eschol Park, Sydney
Members Ride
WH II Caprice, 5.7 2018 Equinox LTZ V
You don't need to bleed the cooling system with an LS1.
 

BlackVXGTS

Well-Known Member
Joined
Aug 14, 2004
Messages
4,409
Reaction score
1,130
Points
113
Location
Melbourne, SE
Members Ride
GEN-F2 GTS A6, VS Clubsport 185 A4
You don't need to bleed the cooling system with an LS1.
Quite correct. Any air trapped in the cooling system will automatically end up in the coolant surge tank over the next week or so. That could be why you needed to top up the coolant. However, two litres does seems to be a little excessive, so keep your eye on the coolant level to make sure it stabilises.
 

Lotto82

New Member
Joined
Jan 31, 2019
Messages
11
Reaction score
0
Points
1
Age
39
Location
Brisbane
Members Ride
Vx ss cammed ls1
Cheers bro. Its seeming ok now. Since i did top it up. And oil leak was just sump gasket. I also re-tensiond the rocker covers but aside from that its fine. Just have to get used to the cam. I think ive mastered the takeoff now. Just needed to find that happy medium between peeling the back tyres and almost stalling it.
 

Lotto82

New Member
Joined
Jan 31, 2019
Messages
11
Reaction score
0
Points
1
Age
39
Location
Brisbane
Members Ride
Vx ss cammed ls1
I also got some heat sheild attached to my abs lines now and took for a strap and it diddnt affect brakes or appear to be over hot in master cyl.
 
Top