Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Car completely dead even with Jumper leads (No ignition lights)

BrisbaneVTOwner

New Member
Joined
Jan 31, 2009
Messages
26
Reaction score
0
Points
0
Members Ride
VE International Sportswagon II
Any thoughts? Can it be a main fuse. Car has started to play up electrically recently, but drove it OK yesterday.

Went to it today and doors would not unlock. Battery was completely dead, but didn't even get ignition lights when connected to mates car via jumper leads??

Many Thanks
 

BrisbaneVTOwner

New Member
Joined
Jan 31, 2009
Messages
26
Reaction score
0
Points
0
Members Ride
VE International Sportswagon II
They all look fine....

The worst is.... all I want to do is drive it to a wreckers and sell to them for $500 :)
 

fitz_vt

Pass Me A Wrench.....
Joined
Nov 2, 2008
Messages
508
Reaction score
3
Points
0
Location
Adelaide - South Side
Members Ride
VT Commodore SII Olympic Edition
Main fuse or bcm might be a faulty memcal all sorts of problems can come up .....
 
Last edited:

fitz_vt

Pass Me A Wrench.....
Joined
Nov 2, 2008
Messages
508
Reaction score
3
Points
0
Location
Adelaide - South Side
Members Ride
VT Commodore SII Olympic Edition
after consulting the gregories check the fuseable links theyre in the enging bay fuse box they you can see if the links broken by looking at them though the clear window on the top of them
 

BrisbaneVTOwner

New Member
Joined
Jan 31, 2009
Messages
26
Reaction score
0
Points
0
Members Ride
VE International Sportswagon II
yeah they look OK thanks....

I've bought a new Berlina Sportswago... pick it up this weekend!!! I just needed my car to last a few more days darn it!! :)
 

fitz_vt

Pass Me A Wrench.....
Joined
Nov 2, 2008
Messages
508
Reaction score
3
Points
0
Location
Adelaide - South Side
Members Ride
VT Commodore SII Olympic Edition
does your odometer appear on the screen down the bottom of the speedo?

Very nice choice in car i must say
 

psycho_smurf

Donating Member
Joined
Aug 24, 2010
Messages
40
Reaction score
28
Points
18
Location
Rockhampton
Members Ride
2003 Crewman V6
If the battery is completely dead and you hook the jumper cables to it, the battery will draw too much current and not enough will be heading to your starter motor and such. Try just using your mates battery in your car, don't go cranking endlessly or it will get flat too. One trick I have used to get me out of trouble a few occasions (do it at your own risk), is start up your mates car, remove the battery (the car will continue to run), put the battery in yours, start yours, Then swap batteries back. Every car manual I've ever read tells you never to do this cause batteries can explode, car electronics can get fried, etc.
 

Cameron P

New Member
Joined
Jun 29, 2010
Messages
1,652
Reaction score
3
Points
0
Location
Quakers Hill, NSW
Members Ride
REDHOT VX SS
lol i did this to my gf's pulsar the other day.. never new the batterys could blow up =S
 
Top