Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

climate control?

NVE_069

New Member
Joined
Mar 1, 2005
Messages
898
Reaction score
2
Points
0
Location
Brisbane
Members Ride
Wh Statesman LS1
i installed my dvd player an screen yesterday an for some reason the light for the climate control dont work the screen part i mean any ideas, it was workin b4 that so i dunno. funny thing is i didnt touch it
 

randomroen

New Member
Joined
Jul 23, 2006
Messages
13
Reaction score
0
Points
1
Location
Canning Vale, W.A
Members Ride
VT Berlina S2
VT-Berlina said:
i installed my dvd player an screen yesterday an for some reason the light for the climate control dont work the screen part i mean any ideas, it was workin b4 that so i dunno. funny thing is i didnt touch it
Even though you didn't touch it, it's very possible that during the instalation, you may have knocked something accidently which has caused a cable or something to disconnect from the back of the climate control.

Does your air conditioning and temperature controls still work without the screen?

This might sound dumb but maybe check all the fuses.
 

daron

wizfiz
Joined
Mar 28, 2006
Messages
1,420
Reaction score
28
Points
48
Location
adelaide
Members Ride
VE SSV
its a very comon prob in vts
the bulbs blow from even the slightest bang/knock
youll need to pull it all out again and remover dash suround and then pull out controls and replace the bulbs
holdens sell them from 8-12 bux each depends where ya go
hes a tip bmw dealers sell same globes for 4.50 each
i doubt the cable fell out as its clipped in they dont just fall out unless someones been in there b4 and stuffed it up
 

myberlina

BAD COP! NO DOUGHNUT!!!
Joined
Aug 16, 2005
Messages
395
Reaction score
1
Points
0
Location
Melbourne, VICTORIA
Members Ride
2006 VE Calais
I fully agree with daron. These globes will blow out even with the simplest knock.

Its really annoying. I should know as the same thing happened to me.
 

wrx884

WA's ASR Rep
Joined
Mar 28, 2006
Messages
3,687
Reaction score
34
Points
48
Age
36
Location
Perth
Members Ride
VT Exec/ VT L67 Spac, 5L VP Calais, 77 TC Gemini
if ya gonna pull out ya climate contols id just solder in some LEDs while ur at it even if its the same colour green they will last longer look better and u wont have 2 worry bout bumpin them n them blownin. a few guys and myself have dun it 2 our cars check out the threds on how 2 do it ;)
 

wrx884

WA's ASR Rep
Joined
Mar 28, 2006
Messages
3,687
Reaction score
34
Points
48
Age
36
Location
Perth
Members Ride
VT Exec/ VT L67 Spac, 5L VP Calais, 77 TC Gemini
daron. said:
http://www.adam.com.au/daron69/test/dash/
i did the full led conversion while mine was apart

hey mate do u have pics of ur intrument cluster with all the LEDs in but not lite up??? im bout 2 do mine like urs but with diff colours but parrelleling the LEDs tho so the light spreads more even rather than usin those T5 wedge bulbs???????
 

NVE_069

New Member
Joined
Mar 1, 2005
Messages
898
Reaction score
2
Points
0
Location
Brisbane
Members Ride
Wh Statesman LS1
yeh everything works bar 2 lights on the buttons and the screen but all work normal just the lights
 

daron

wizfiz
Joined
Mar 28, 2006
Messages
1,420
Reaction score
28
Points
48
Location
adelaide
Members Ride
VE SSV
wrx884 said:
hey mate do u have pics of ur intrument cluster with all the LEDs in but not lite up??? im bout 2 do mine like urs but with diff colours but parrelleling the LEDs tho so the light spreads more even rather than usin those T5 wedge bulbs???????
ummm thats the only pics i have sorry
couple hits with leds
1 sand the end a llittle bit so it doesnt shine through in one spot bright
2 add texta or liquid paper to tip of led same reason
 
Top