Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Clunk from air vents

nathanVY

such boost
Joined
Dec 27, 2009
Messages
1,785
Reaction score
15
Points
38
Location
Geelong, VIC
Members Ride
2003 VY LS1 Turbo Calais, 2005 4Gen Liberty Wagon
Hey guys, just wanting to see if anyone knows about this so I can fix it while I have the dash out.
After I fixed my climate control vacuum issue all the vents started working but I did notice a loud clunk sound whenever the air vents switched to center for the first time - like the vac was too much and it was smashing something too hard.

Anyone had this problem? All the vents worked fine it was just annoying.


Advice much appreciated, cheers
 

MaFaLu

New Member
Joined
Oct 8, 2010
Messages
25
Reaction score
0
Points
0
Location
Mount Martha, SE Victoria
Members Ride
94 Toyota Lexcen Newport (VR S2 Calais)
Hey there, don't have much advice on it, but mine fitted with the same climate control as yours (loving your car btw) does the same thing when switching from center vents to screen defogger etc, not quite sure if its normal would love to know myself.
 

nathanVY

such boost
Joined
Dec 27, 2009
Messages
1,785
Reaction score
15
Points
38
Location
Geelong, VIC
Members Ride
2003 VY LS1 Turbo Calais, 2005 4Gen Liberty Wagon
Hey there, don't have much advice on it, but mine fitted with the same climate control as yours (loving your car btw) does the same thing when switching from center vents to screen defogger etc, not quite sure if its normal would love to know myself.
lol thanks man, yeah I don't know if it's normal or not! might call the wreckers tomorrow see if they know.
 

MaFaLu

New Member
Joined
Oct 8, 2010
Messages
25
Reaction score
0
Points
0
Location
Mount Martha, SE Victoria
Members Ride
94 Toyota Lexcen Newport (VR S2 Calais)
Haha, ok then. Not sure if its a real worry, ive had the car since it had 150,XXX km's on the clock its now done 200,XXX km's and it clunked the whole time, i think its just the vents switching over i cant imagine vacume could cause too much damage, but hey im no air-con expert.
 
Top