Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Code 42 issues

vpkiwi

Lucky13
Joined
Sep 20, 2005
Messages
5
Reaction score
1
Points
0
Age
42
Location
Melbourne, VIC
Members Ride
92VP Commodore
Hey guys and gals,

I know there are many threads on this subject but I have quite a unique problem that I was hoping you could maybe help me with.

A couple days ago my 92 V6 VP started running like crap (missing, stalling) and code 42 was being shown. So I did some research on here and other places and decided to replace the coil packs and the circuit board it sits on but it still is showing code 42.
But the strange thing is my aircon cuts in and out (it worked before) and when the black and white wires are bridged (to check the codes) the engine fan relay goes mental clicking on and off, so much it has burned itself from getting to hot.
My next step is to replace the ECU but I thought I would just run it past you guys first to see if you have any other ideas, any help is much appreciated :)
 

db_notso

diagnostic technician...
Joined
Oct 2, 2010
Messages
979
Reaction score
7
Points
0
Age
34
Location
sunshine coast, qld
Members Ride
vt v6, mods(susp brakesetc...)

vpkiwi

Lucky13
Joined
Sep 20, 2005
Messages
5
Reaction score
1
Points
0
Age
42
Location
Melbourne, VIC
Members Ride
92VP Commodore
Thanks mate but I used to be a mechanic and have checked codes before in commodores and its not the way im checking the codes that is making the fan relay freak out.

I have bridged the two wires in the connector next to the ECU and when that is done the fan will come on and stay on, but my fan goes on and off and the relay clicks on and off while showing code 42.
I am leaning towards ECU but I have done the "tap on it" trick and the code 42 still came up, but interestingly when i first start the car up it takes a couple of seconds (3 maybe) till the check engine light shows up and it starts playing up again so off to pick a part tomorrow to get an ECU I think so then at least we can rule that out.
But I just found it weird that my aircon is being effected by this code 42??? :-\
 

db_notso

diagnostic technician...
Joined
Oct 2, 2010
Messages
979
Reaction score
7
Points
0
Age
34
Location
sunshine coast, qld
Members Ride
vt v6, mods(susp brakesetc...)
maybe the signal parameter from ecu..... (not likely unless is damaged or extremely old as is an internal hard wired circuit- but entirely possible)

not sure on this model but codes relating to ignition can affect the timing of everything else and shut off ac in case load from ac affecting by a too lower idle (why revs bump up ac on?)

let us no how you go with ecu swap....

oh if that relay burns and clicks on and off means signal side of relay is droppping signal in and out....
if its burnt then its drawing too many amps......
possibly an earth issue with you ignition circuit?
 

vpkiwi

Lucky13
Joined
Sep 20, 2005
Messages
5
Reaction score
1
Points
0
Age
42
Location
Melbourne, VIC
Members Ride
92VP Commodore
Thanks for the advice mate, it seems the ECU swap has fixed it !!! :) So all good, it seems if you get code 42 and a few weird things happening then an ECU swap is definitely an option ;-)
 

db_notso

diagnostic technician...
Joined
Oct 2, 2010
Messages
979
Reaction score
7
Points
0
Age
34
Location
sunshine coast, qld
Members Ride
vt v6, mods(susp brakesetc...)
so fixed great~!
must be an internal earth inside ecu that has failed causing excessive backfeed of power through ignition circuit???
thats a rare fault to have, i will keep this in mind thanks~!
 
Top