Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Help needed!

Dan24

New Member
Joined
Jun 8, 2010
Messages
101
Reaction score
0
Points
0
Members Ride
2003 VY SS
hey this arvo i decided to put a new cluster face into my VX all was fine, put the needles back on and after a bit of fiddling got em working except for the fuel gauge one, iv tried 20 odd times off putting it back on at diffrent widths to the face etc and nothing...

any ideas?
 

Mirkz

New Member
Joined
Apr 19, 2010
Messages
479
Reaction score
3
Points
0
Location
WA
Members Ride
GSXR1000
if you put the old one back on does the fuel gauge work?
If so, perhaps you have an issue with the new cluster ?
 

Dan24

New Member
Joined
Jun 8, 2010
Messages
101
Reaction score
0
Points
0
Members Ride
2003 VY SS
i only changed the face, so i took of the needle replaced the face, replaced the needle and now the gauge dont work.....
 

Mick1988

W.A. Cruise Moderator
Joined
Apr 6, 2008
Messages
786
Reaction score
12
Points
18
Age
32
Location
Perth, Western Australia
Website
www.sarichtechnology.com
Members Ride
Too many to list......
Remove the binnacle and install the cluster. Try moving the needle by hand and see if it's stuck. Perhaps you've slightly bent the pin the needle sits on and that has caused for it to rub against the gauge face. Check the plastic sleeve of the needle to make sure you haven't cracked it also. Only other thing to try if both of these check out is a little bit of super glue to make sure the pin isn't slipping inside the sleeve. If all else fails, you've damaged the gauge.
 
Top