Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

knocking noise in front end of my vp whenever i stop accelerating

ashley17

New Member
Joined
Jun 22, 2013
Messages
1
Reaction score
0
Points
0
Location
mount gambier
Members Ride
vp commodore
it only started earlier today, before that there was not a single noise. starting heading back after doing some shopping etc and in the front left there is a really bad knocking type noise which feels like its tugging on that side. the only time it doesnt happen is when i accelerate. any help would be great as its our family car and need to know what to do asap
 

Jxfwsf

Well-Known Member
Joined
Feb 20, 2011
Messages
4,852
Reaction score
97
Points
48
Location
Aus
Members Ride
commodore
hit any speed humps a bit fast lately?

Could be a shagged engine mount, grab a torch and look under the front of the car and inspect the engine mounts, there is a long rod through them and when the mount sags with age this hits the k-frame making a horrible noise/vibration.

vt eng mnt.jpg

Could be exhaust hittingh the body, but this is usually under acceleration.
 

someguy360

Beer, bacon and speed parts.
Joined
Jan 29, 2011
Messages
2,589
Reaction score
1,104
Points
113
Location
SA
Members Ride
94' VR 304 - 05' Navara - 12' Sorento
Check all your front end bushes.

My Z bar to K frame bushes were cracked, just replaced them yesterday....no more clunk.

Most bushes in the front end will knock when worn.
 
Top