Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

l67 Balancer Question

Dandrenat

New Member
Joined
Oct 21, 2013
Messages
7
Reaction score
0
Points
0
Location
whitsundays
Members Ride
2001 VX S l67
Hey Guys, after having my car sitting in the shed for about 14 months i have finally put back together but have a couple of questions.


Vehicle is a 2001 VX Series 2 S Pac
when i parked it up it was fitted with a FIT 10psi pulley and i had Fit 1:91 Roller rockers (that made a horrible noise when i first installed but had learned on here that i may have needed new pushrods too)
Also has generic extractors (honestly can't remember the brand of them)
I purchased from Mace the New pushrods. manifold spacer (6mm ) as well as a Cold air Induction kit.
(have also done the boost solenoid delete at this stage so hopefully am not loosing any boost anywhere)

I finally started the car again the other day and i have a squeek comming from the Harmonic Balancer (have taken all belts off and run for a minute and squeek is still there so that has to be where its comming from)

my main question is if i purchase the Mace 5% Overdrive Race Performance Balancer will i have any issue's with already running 10PSI.

I did not port the blower or intake mani as at the time i felt it was out of my ability and had not heard the car make a noise in 14 months and was getting emo.

any advice would be greatly appreciated
 

MACE

Well-Known Member
Joined
Mar 30, 2008
Messages
3,153
Reaction score
65
Points
48
Hi Dandrenat,

Thank you for your enquiry:

"Hey Guys, after having my car sitting in the shed for about 14 months i have finally put back together but have a couple of questions."
No problems.

"Vehicle is a 2001 VX Series 2 S Pac when i parked it up it was fitted with a FIT 10psi pulley and i had Fit 1:91 Roller rockers (that made a horrible noise when i first installed but had learned on here that i may have needed new pushrods too) Also has generic extractors (honestly can't remember the brand of them) I purchased from Mace the New pushrods. manifold spacer (6mm ) as well as a Cold air Induction kit. (have also done the boost solenoid delete at this stage so hopefully am not loosing any boost anywhere)"
Nice.

"I finally started the car again the other day and i have a squeek comming from the Harmonic Balancer (have taken all belts off and run for a minute and squeek is still there so that has to be where its comming from)"
Assuming you have also removed the supercharger belt as well, are you 100% sure that the squeak is coming from the harmonic balancer?

"my main question is if i purchase the Mace 5% Overdrive Race Performance Balancer will i have any issue's with already running 10PSI."
Given your current setup, the larger suggested balancer should bump it up by 0.5psi.

"I did not port the blower or intake mani as at the time i felt it was out of my ability and had not heard the car make a noise in 14 months and was getting emo."
That's fair enough.

"any advice would be greatly appreciated"
Done.

If you have any questions please don't hesitate to ask

Kindest Regards,
Steve
 

Dandrenat

New Member
Joined
Oct 21, 2013
Messages
7
Reaction score
0
Points
0
Location
whitsundays
Members Ride
2001 VX S l67
yup Both Belts Removed and still had the noise.

it is kind of an assumption that the noise is from the balancer area as both belts removed (so no other pulleys spinning )

while it was running i listened to both rocker covers and the Passanger Side bank is noisier then the Drivers, But I do not believe that is the sound i am hearing
as to my ear it is coming lower down then the covers (tho i intend to pull the cover off anyway and just double check things are all good under there)

the other thing that could be causing me issue's is the fact when i was filling with coolant i did forget to put in a bolt in the front timing cover and coolant
came through there, So maybe i have to pull the balancer off and cover as well and make sure i have not gotten coolant in to where my timing chain is
(completely unsure if this is even possible, but very well could be and also explain why the noise appears to be coming from that area.
 

chargedvx6

Active Member
Joined
Dec 9, 2006
Messages
1,866
Reaction score
14
Points
38
Members Ride
VY SII HBD Calais L67
The coolant would have travelled out through the timing cover so no stress there. The balancer could only be making a noise from a dry front crank seal or scraping on the plastic shroud behind it that captures the loom. I'd suggest driving the car a little and see if the seal gets wet n happy :) Should quieten up like usual
 

Dandrenat

New Member
Joined
Oct 21, 2013
Messages
7
Reaction score
0
Points
0
Location
whitsundays
Members Ride
2001 VX S l67
thanks for the advice, at the moment the car is still sitting in the shed with no lights or front bar (or registration :lol: ) so the drive is not an option really.

Maybe just putting it under load in the shed will help?

(ie in Drive, foot on brake and some throttle )

Thinking i will pull the cover off the noisier bank at lunch time anyway and just nip up the rocker bolts just in case too.

The other thing that could be causing noise (and completely possible with me ) is i have dropped a bolt or nut and its just behind the balancer making some noise :lol:
 

delcowizzid

on holiday
Joined
Jul 8, 2008
Messages
6,983
Reaction score
428
Points
83
Location
NZ
Members Ride
в∞ѕтεכ √&
pushrods rubbing on the holes in the head can squeak too
 

Dandrenat

New Member
Joined
Oct 21, 2013
Messages
7
Reaction score
0
Points
0
Location
whitsundays
Members Ride
2001 VX S l67
i was carefull to make sure these were centred, But will check as well (as its easy to check)

Thanks for the tip
 
Top