Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

ls1 bogging down off take off!!

vtr8clubby

New Member
Joined
May 21, 2012
Messages
27
Reaction score
0
Points
0
Location
Vic
Members Ride
VTII HSV R8
Hey people, ive got a vt series 2 clubby r8 ls1 thats been rebuilt with the only mod I could afford at the time was pacemaker 4 into 1 extractors with lest than 20,000kms (3 years) and now it seems to take off like a slug untill it get to around 2500rpm, it makes a really troughty inducton noise and then takes off really slowly! Its got new leads, spark plugs and air filter I have done everything thing apart from maf' o2's and fuel filter!! (Because i don t have the money) Is there anthing im over looking?
 

accentstencil

Well-Known Member
Joined
Jun 30, 2005
Messages
8,273
Reaction score
469
Points
83
Age
69
Location
Eschol Park, Sydney
Members Ride
WH II Caprice, 5.7 2018 Equinox LTZ V
Oxygen sensors could be the cause.
 

vtr8clubby

New Member
Joined
May 21, 2012
Messages
27
Reaction score
0
Points
0
Location
Vic
Members Ride
VTII HSV R8
:spot on::spot on:I thought it might be, the other thing forgot to mention is the check engine light comes on after it's warm and I take my foot off the accelerator to change speeds (I do alot of highway driving) I don't know if that helps at all though, any help is good help but :)
 

Big-Al

Banned
Joined
Oct 23, 2012
Messages
1,838
Reaction score
14
Points
0
Location
Aussie and proud
Members Ride
VY SS 5.7 M6
+1 for oxygen sensors - would also explain the check engine light.
 

Not_An_Abba_Fan

Exhaust Guru
Joined
Aug 18, 2006
Messages
14,638
Reaction score
1,324
Points
113
Location
Bunbury, WA
Members Ride
Strange Rover
How long have the extractors been on? New extractors will fail O2 sensors as the coating burns off it contaminates them. Replace the O2 sensors and it should improve.

Also, fitting 4-1's will increase your mid to high rev torque so much that it feels like it has lost some down low. But in actual fact, the difference between the bottom end and mid to high is greater now so it just feels like there is less bottom end.
 

accentstencil

Well-Known Member
Joined
Jun 30, 2005
Messages
8,273
Reaction score
469
Points
83
Age
69
Location
Eschol Park, Sydney
Members Ride
WH II Caprice, 5.7 2018 Equinox LTZ V
Finding out why the check engine light is coming on may hold the key to your problem. Have the error codes checked, will probably be O2 sensors.
 

vtr8clubby

New Member
Joined
May 21, 2012
Messages
27
Reaction score
0
Points
0
Location
Vic
Members Ride
VTII HSV R8
Alright pretty much what I thought the oxygen sensors ether way im going to take it to the mechanics tomorrow so they can put the scan tool on it.
The extractors shouldnt be the problem they have been on it since the motor was rebuilt and it hasn't missed a beat since in 17,000kms guess I'll find out tomorrow, I'll keep you poasted for future reference any way.
 
Top