Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

LS1 Injector question

Heffer_Slayer

New Member
Joined
Jan 6, 2007
Messages
519
Reaction score
2
Points
0
Location
Victoria
Members Ride
VX Berlina
Hey all. Yet another thread, with another question :p

I am pretty sure the reason my car is not firing straight away after letting sit for a little bit is due to the injectors.

I still have the original injectors from memory (they are black ones). Orings are worn, I recken they are leaking too, anyway to easily verify if they are?

If i change them, will i need to retune the car? Do i need to get the same identical ones? Or can i go aftermarket?

Where is a good place to grab a new set of fuel injectors?

They are stock as far as I know of.
 

Munz

Right Foot Action
Joined
Jan 23, 2011
Messages
2,276
Reaction score
4
Points
38
Location
Brisbane NTH
Members Ride
VZ Calais LS1 / VL RB30e daily
How's your battery? Mine was doing the same until I replaced the battery
If it is injectors and you replace with oem spec you won't need a retune. They are easy enough to remove and unless there are no physical sign of leakage you could have them checked by someone that cleans injectors. Personally if they're faulty I would replace with brand new ones

Are we talking VT or VX LS1?
 

Heffer_Slayer

New Member
Joined
Jan 6, 2007
Messages
519
Reaction score
2
Points
0
Location
Victoria
Members Ride
VX Berlina
Battery seems fine, the car cranks over fast like it should.

All the orings look stuffed on my injectors, I had them out over the weekend while changing my knock sensor, and pretty sure they were dripping a little bit of fuel (only one drop) with them out of the car.

I might actually take the rail/injectors out while keeping it connected to the fuel line and prime the pump to see if it leaks.

The rear passanger side injector had a residue around where it sits.
Also i noticed on the intake manifold, there are little grooves which looks like a guide to where the injectors are meant to sit. Though my injectors have to guides to put them in...is this normal?

Its a VX LS1 Berlina
 
Top