Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

My Commodore VS II, 1995

Raido

New Member
Joined
May 26, 2013
Messages
1
Reaction score
0
Points
0
Age
33
Location
Toowoomba
Members Ride
Commodore VS II
Hey guys!
I'm pretty bored s I thought i'm gonna make a thread of my new daily ride so i could make some small diary and ask some advise sometimes if i need one.
So i picked up this nice looking car couple of weeks ago near Toowoomba. I needed car very fast and luckily day before going car hunting in Toowoomba i saw ad about this Commy. From all the offers this was the best. Good price, nice looking. Although there are some bad points also.
1. Passenger side headlight was broken. Got new one from Sunshine Coast car shop.
2. Dents, scratches - i'm not gonna fix them cause i'm just staying in Australia for 1 or 2 years and then i'm gonna sell it.
3. Cover gasket leak. have to find time to change it.
4. Power steering hoses were oily. Just cleaned and tightened bracket. We'll see if it leaks more.
5. Fuel gauge shows me bullsh*t. Just wiggles up and down.
6. Heater doesn't work on position 1 and 2. Already made the search here and just need that thing with springs and get it changed.
7. Engine mounts need to be changed.
More or less the car runs well, engine is very smooth, changes gears well and looks good also.

The Details:
Model: 1995 VSII Commodore Executive
Build: 1995
Colour: Custom white
Engine: 3.8L V6 Ecotec
Gearbox: 4L60E
Diff: Stock
Brakes: Stock
Wheels: 18"
Exterior: Custom paint
Interior: Stock, Sony stereo, stock speakers
Km: 230xxx

So here are some pics.
IMGP3475.JPG


IMGP3484.JPG


IMGP3485.JPG


I also have second car back home and i really miss driving with it but the time will come.
Here's my beauty
IMG_8059.jpg


Cheers
 

VS_Pete

Donating Member
Joined
Dec 23, 2007
Messages
4,937
Reaction score
22,279
Points
113
Location
Brisbane
Members Ride
VE II SV6 MY12 SPORTWAGON
Looks good not much to fix good luck with it.
 

Raido

New Member
Joined
May 26, 2013
Messages
1
Reaction score
0
Points
0
Age
33
Location
Toowoomba
Members Ride
Commodore VS II
thanks mate!
Last week did one trip, approx 750km. And for that body and that engine car is really economic. 7,5L/100km. Mostly on the highway 100-110km/h
Although it's quite bumpy ride on those Australian roads.
Also what could be the problem: temp doesn't get up more then one level while driving. When i stopped for couple of minutes and let the engine run, then it raised between center and quarter.
Is it thermostat fault?
 
Top