Welcome to Just Commodores, a site specifically designed for all people who share the same passion as yourself.

New Posts Contact us

Just Commodores Forum Community

It takes just a moment to join our fantastic community

Register

Radiator and heater hoses smell

NeddyBear

Veteran Mountain Biker
Joined
May 5, 2011
Messages
1,488
Reaction score
196
Points
63
Location
Rubyvale, Qld
Members Ride
2004 2.5L Subaru Outback
Yesterday I worked for 8 hours and replaces all the heater and radiator hoses and after checking for leaks I found the top radiator hose was a tad smokey and the remainder gave off a strange hot rubber smell so I'm wondering if this is normal for the Gates product. I purchased all the hoses as a kit from Repco for $95.00.
 

Nut Kracker

Donating Member
Joined
Oct 18, 2012
Messages
4,760
Reaction score
137
Points
63
Age
62
Location
Echuca Vic.
Members Ride
VT SS 304ci (195i)
I've got the blue coloured Gates upper and lower radiator hoses. Have had them on for a fair while.
I didn't experience what you did, that I know of, but I'd say it's just because they are new and will settle down in time.
Keep an eye on them just the same. But they should be ok.
I'd say it's like putting a new exhaust on, you get that "burn in smell", then it fades.
 

NeddyBear

Veteran Mountain Biker
Joined
May 5, 2011
Messages
1,488
Reaction score
196
Points
63
Location
Rubyvale, Qld
Members Ride
2004 2.5L Subaru Outback
I to would have like either the red or the blue coloured hoses but the black ones do the same job. Weve now travelled 1200 klms since and all the strange smell is gone.
When fitting all the hoses I also replaced the therostate, the coolant and the heater valve.
 
Top